Cisco error invalid input detected at marker

Cisco CLI Error - Invalid input detected at '^' marker. An explanation of what this means and when it happens. Why this happens for show commands

In what CLI Mode does this error appear?

This message is not restricted to a particular CLI Mode or to a particular CLI command or task.

What does this error mean?

This error indicates that we have made an error while typing in a CLI command. This error message is preceded by a line with the single character ‘^’. There may be multiple errors in a line that we have typed in at the CLI. The ‘^’ indicates the first instance of an error in the line typed in.

For example, suppose we were attempting to configure an IP address on a router interface. We attempt to configure it as follows:

Router Console

Router#config t

Router(config)#int gi0/1

Router(config-if)#ip adress 10.100.100.1. 255.255.255.0

Router(config-if)#ip ad^

% Invalid input detected at ‘^’ marker.

Router(config-if)#

Looking at the command that we have typed in, we can see that we have misspelled the word «address». The ‘^’ under the letter ‘r’ in the word «address» informs us that there is an error at the letter ‘r’.

We can correct the error and type in the command again.

Router Console

Router#config t

Router(config)#int gi0/1

Router(config-if)#ip adress 10.100.100.1. 255.255.255.0

Router(config-if)#ip ad^

% Invalid input detected at ‘^’ marker.

Router(config-if)#ip address 10.100.100.1. 255.255.255.0

Router(config-if)#ip address 10.100.100.1^

% Invalid input detected at ‘^’ marker.

Router(config-if)#

We have corrected the error in the word «address» but we notice that there is another error message. This time we notice that the ip address that we are trying to configure has an extra ‘.’ at the end. The ‘^’ indicates that there is an error at this location in the line that we have typed in.

We will re-enter the command without the extra ‘.’

Router Console

Router#config t

Router(config)#int gi0/1

Router(config-if)#ip adress 10.100.100.1. 255.255.255.0

Router(config-if)#ip ad^

% Invalid input detected at ‘^’ marker.

Router(config-if)#ip address 10.100.100.1. 255.255.255.0

Router(config-if)#ip address 10.100.100.1^

% Invalid input detected at ‘^’ marker.

Router(config-if)#ip address 10.100.100.1 255.255.255.0

Router(config-if)#

This time the command is accepted with no warnings or error messages.

Point to note: There may be multiple errors in a line, but the ‘^’ character appears underneath the first error that is found. All of the errors are not highlighted at the same time.

A common occurence of this error with the «show» command

Take a look at the following example:

Router Console

Router(config)#sh run

Router(config)#s^

% Invalid input detected at ‘^’ marker.

Router(config)#

We are attempting to run the «show running-config» command. Why do we see an error message instead of the desired output?

Upon further inspection, we realize that we are currently in Global Configuration Mode (as indicated by the word ‘config’ in the CLI prompt). Most of the «show» commands are available in Privileged EXEC Mode (although a large number of them are also available in User EXEC Mode).

In this instance, if we want to see the running configration, we would need to either precede the command with the word «do», or exit back into Privileged EXEC Mode and run the «show run» command.

Router Console

Router(config)#sh run

Router(config)#s^

% Invalid input detected at ‘^’ marker.

Router(config)#do sh run

Building configuration…

Current confguration: 2440 bytes
!
version 15.5
no service timestamps log datetime msec
no service timestamps debug datetime msec
.
<output truncated>
.

Router(config)#

If we run into an «Invalid input detected at ‘^’ marker» error while attempting to run a «show» command we should always check to confirm that we are not in a Configuration Mode.

Remember: The «show running-config» and «show startup-config» commands are only available in Privileged EXEC Mode — they are not available in User EXEC Mode!

Other common occurences of this error

Interface command

If you run into this error while trying to enter the Interface Specific Configuraiton Mode using the interface command, it is possible that the interface label has been incorrectly typed in.

In the following example, the switch only has 26 gigabitethernet interfaces (0/1 to 0/26). We are attempting to configure interface gi 0/27. The ‘^’ character indicates that 0/27 is not a valid interface label.

Switch Console

Switch(config)#interface gigabitethernet 0/27

Router(config)#interface gigabitethernet 0/2^

% Invalid input detected at ‘^’ marker.

Switch(config)#

In the following example, we are attempting to configure interface gigabitethernet 3/10 on a switch stack. The stack only consists of 2 physical switches — the range of valid interfaces for the stack is 0/1 — 0/26 and 1/1 — 1/26. Interface gigabitethernet 3/10 is not a valid interface for this switch stack.

Switch Console

Switch(config)#interface gigabitethernet 3/10

Router(config)#interface gigabitethernet ^

% Invalid input detected at ‘^’ marker.

Switch(config)#

Ip address command

If you run into this error while trying to configure an IP address on an interface, make a note of where the ‘^’ character appears. In the following example, the ‘^’ character appears at the beginning of the word «address».

Switch Console

Switch(config)#interface gigabitethernet 0/1

Switch(config-if)#ip address 192.168.0.1 255.255.255.0

Router(config-if)#ip ^

% Invalid input detected at ‘^’ marker.

Switch(config-if)#

The position of the ‘^’ character seems to indicate that the word address is not a valid keyword or parameter in the current command context. We confirm this by entering ‘?’ after the first word of the command as follows:

Switch Console

Switch(config)#interface gigabitethernet 0/1

Switch(config-if)#ip address 192.168.0.1 255.255.255.0

Router(config-if)#ip ^

% Invalid input detected at ‘^’ marker.

Switch(config-if)#ip ?

. … <output truncated>
arp Configure ARP features
dhcp Configure DHCP parameters for this interface
. … <output truncated>

Switch(config-if)#ip

The context sensitive help indicates that the ip address command is not a valid command in the current context. What could be the reason for this? The most likely reason is that we are on a Layer 2 switch attempting to configure an IP address on a Layer 2 interface. IP addresses can only be configured on Layer 3 interfaces.

Содержание

  1. Cisco CLI Error: % Invalid input detected at ‘^’ marker
  2. In what CLI Mode does this error appear?
  3. What does this error mean?
  4. A common occurence of this error with the «show» command
  5. Other common occurences of this error
  6. Interface command
  7. Ip address command
  8. Cisco: сообщения об ошибках консоли CLI
  9. Андрей Волков
  10. The main error messages in CLI
  11. The main error messages in CLI
  12. % Ambiguous command.
  13. % Incomplete command.
  14. % Invalid input detected at “^” marker.
  15. Invalid input detected at marker cisco что это
  16. Ошибка = % Invalid input detected at ‘^’ marker. = cisco packet tracer — циско пэкет трайсер
  17. Cisco CLI Error: % Invalid input detected at ‘^’ marker
  18. What does this error mean?
  19. A common occurence of this error with the «show» command
  20. Other common occurences of this error
  21. Interface command
  22. Ip address command
  23. Invalid input detected at marker cisco что это

Cisco CLI Error: % Invalid input detected at ‘^’ marker

In what CLI Mode does this error appear?

This message is not restricted to a particular CLI Mode or to a particular CLI command or task.

What does this error mean?

This error indicates that we have made an error while typing in a CLI command. This error message is preceded by a line with the single character ‘^’. There may be multiple errors in a line that we have typed in at the CLI. The ‘^’ indicates the first instance of an error in the line typed in.

For example, suppose we were attempting to configure an IP address on a router interface. We attempt to configure it as follows:

Looking at the command that we have typed in, we can see that we have misspelled the word «address». The ‘^’ under the letter ‘r’ in the word «address» informs us that there is an error at the letter ‘r’.

We can correct the error and type in the command again.

We have corrected the error in the word «address» but we notice that there is another error message. This time we notice that the ip address that we are trying to configure has an extra ‘.’ at the end. The ‘^’ indicates that there is an error at this location in the line that we have typed in.

We will re-enter the command without the extra ‘.’

This time the command is accepted with no warnings or error messages.

Point to note: There may be multiple errors in a line, but the ‘^’ character appears underneath the first error that is found. All of the errors are not highlighted at the same time.

A common occurence of this error with the «show» command

Take a look at the following example:

We are attempting to run the «show running-config» command. Why do we see an error message instead of the desired output?

Upon further inspection, we realize that we are currently in Global Configuration Mode (as indicated by the word ‘config’ in the CLI prompt). Most of the «show» commands are available in Privileged EXEC Mode (although a large number of them are also available in User EXEC Mode).

In this instance, if we want to see the running configration, we would need to either precede the command with the word «do», or exit back into Privileged EXEC Mode and run the «show run» command.

If we run into an «Invalid input detected at ‘^’ marker» error while attempting to run a «show» command we should always check to confirm that we are not in a Configuration Mode.

Remember : The «show running-config» and «show startup-config» commands are only available in Privileged EXEC Mode — they are not available in User EXEC Mode!

Other common occurences of this error

Interface command

If you run into this error while trying to enter the Interface Specific Configuraiton Mode using the interface command, it is possible that the interface label has been incorrectly typed in.

In the following example, the switch only has 26 gigabitethernet interfaces (0/1 to 0/26). We are attempting to configure interface gi 0/27. The ‘^’ character indicates that 0/27 is not a valid interface label.

In the following example, we are attempting to configure interface gigabitethernet 3/10 on a switch stack. The stack only consists of 2 physical switches — the range of valid interfaces for the stack is 0/1 — 0/26 and 1/1 — 1/26. Interface gigabitethernet 3/10 is not a valid interface for this switch stack.

Ip address command

If you run into this error while trying to configure an IP address on an interface, make a note of where the ‘^’ character appears. In the following example, the ‘^’ character appears at the beginning of the word «address».

The position of the ‘^’ character seems to indicate that the word address is not a valid keyword or parameter in the current command context. We confirm this by entering ‘?’ after the first word of the command as follows:

. .
arp Configure ARP features
dhcp Configure DHCP parameters for this interface
. .

The context sensitive help indicates that the ip address command is not a valid command in the current context. What could be the reason for this? The most likely reason is that we are on a Layer 2 switch attempting to configure an IP address on a Layer 2 interface. IP addresses can only be configured on Layer 3 interfaces.

Want to test your networking skills with hands-on configuration and troubleshooting questions? Try out the free Workshops section of this website here: Workshops (Login required).

Read how to use the device simulators on this website here: Workshops — General Instructions

Источник

Cisco: сообщения об ошибках консоли CLI

Андрей Волков

Системное, сетевое администрирование +DBA. И немного программист!)) Профиль автора.

При работе в консоли Cisco CLI вы можете увидеть три типа сообщений об ошибках:

  • Ambiguous command (Неоднозначная команда)
  • Incomplete command (Неполная команда)
  • Invalid input (Некорректный ввод)

Сообщение об ошибке

Смысл

Что делать?

% Ambiguous Command: “ show con ”

Введено недостаточно символов, чтобы устройство могло распознать команду.

Повторно введите команду со знаком вопроса ( ? ) сразу после последнего символа:

show con?

Будут отображены все возможные ключевые слова

Для выполнения команды необходимо ввести дополнительные параметры.

Повторно введите команду со знаком вопроса ( ? ). Поставьте пробел между командой и вопросительным знаком ( ? )

% Invalid input detected at ^ marker

Введенная команда содержит ошибку. Знак ^ отмечает место ошибки.

Повторно введите команду, исправив ошибку в месте расположения файла ^ . Если вы не уверены, в чем заключается ошибка, повторно введите команду со знаком вопроса ( ? ) в месте ошибки, чтобы отобразить доступные команды или параметры.

Источник

The main error messages in CLI

The main error messages in CLI

Please enable JavaScript

If you make a mistake when entering a command in the CLI, or if the command is incomplete, you will get an error message like this

error messages meaning
% Ambiguous command. Can’t uniquely identify the command.
% Incomplete command. The command you entered is incomplete.
% Invalid input detected at “^” marker. The “^” is incorrect.

Table The main error messages in CLI

% Ambiguous command.

The error message “% Ambiguous command.” is displayed if the command cannot be uniquely identified. If you enter the command in an abbreviated form, you must enter it to the point where it is uniquely identified.

The following is an example of a “% Ambiguous command.” error message

In this example, you would type “conf t” to enter global configuration mode, but you would type “con t” to enter global configuration mode. There are multiple commands that start with “con” and they cannot be uniquely identified. In such cases, the “% Ambiguous command.” will displayed

% Incomplete command.

The error message “% Incomplete command.” appears if you do not specify the required parameters for the command you entered. Make sure you know which parameters to provide.

The following is an example of a “% Incomplete command.” error message.

The ip address command, which sets the IP address for an interface, requires you to specify the IP address and subnet mask. If you enter only the ip address, the parameters are incomplete. That’s why “% Incomplete command.” is displayed. To check the parameters you need, use the help.

% Invalid input detected at “^” marker.

The error message “% Invalid input detected at “^” marker.” is mainly shown when the command is misspelled. Make sure the command is spelled correctly.

The following is an example of “% Invalid input detected at “^” marker.

In this example, the “enable secret” command to set the password for privileged EXCE mode is spelled incorrectly. The wrong part is indicated by the “^” sign. You have misspelled “secret” as “secrt”.

To avoid misspelling commands, make use of command completion.

For CLI help and completion, see the following articles

Источник

Invalid input detected at marker cisco что это

Ошибка = % Invalid input detected at ‘^’ marker. = cisco packet tracer — циско пэкет трайсер

может возникнуть при «копипасте» — копировании (клик правой кнопкой мыши по консоли -> «вставить») комадны в консоль управления маршрутизатором.

если же набрать её самомстоятельно — то всё работает нормально —
у меня такая проблема наблюдалась с

На практике,правда, можно столкнуться и с такой ситуацией (решение в другом случае)

Cisco CLI Error: % Invalid input detected at ‘^’ marker

This message is not restricted to a particular CLI Mode or to a particular CLI command or task.

What does this error mean?

This error indicates that we have made an error while typing in a CLI command. This error message is preceded by a line with the single character ‘^’. There may be multiple errors in a line that we have typed in at the CLI. The ‘^’ indicates the first instance of an error in the line typed in.

For example, suppose we were attempting to configure an IP address on a router interface. We attempt to configure it as follows:

Looking at the command that we have typed in, we can see that we have misspelled the word «address». The ‘^’ under the letter ‘r’ in the word «address» informs us that there is an error at the letter ‘r’.

We can correct the error and type in the command again.

We have corrected the error in the word «address» but we notice that there is another error message. This time we notice that the ip address that we are trying to configure has an extra ‘.’ at the end. The ‘^’ indicates that there is an error at this location in the line that we have typed in.

We will re-enter the command without the extra ‘.’

This time the command is accepted with no warnings or error messages.

Point to note: There may be multiple errors in a line, but the ‘^’ character appears underneath the first error that is found. All of the errors are not highlighted at the same time.

A common occurence of this error with the «show» command

Take a look at the following example:

We are attempting to run the «show running-config» command. Why do we see an error message instead of the desired output?

Upon further inspection, we realize that we are currently in Global Configuration Mode (as indicated by the word ‘config’ in the CLI prompt). Most of the «show» commands are available in Privileged EXEC Mode (although a large number of them are also available in User EXEC Mode).

In this instance, if we want to see the running configration, we would need to either precede the command with the word «do», or exit back into Privileged EXEC Mode and run the «show run» command.

If we run into an «Invalid input detected at ‘^’ marker» error while attempting to run a «show» command we should always check to confirm that we are not in a Configuration Mode.

Remember : The «show running-config» and «show startup-config» commands are only available in Privileged EXEC Mode — they are not available in User EXEC Mode!

Other common occurences of this error

Interface command

If you run into this error while trying to enter the Interface Specific Configuraiton Mode using the interface command, it is possible that the interface label has been incorrectly typed in.

In the following example, the switch only has 26 gigabitethernet interfaces (0/1 to 0/26). We are attempting to configure interface gi 0/27. The ‘^’ character indicates that 0/27 is not a valid interface label.

In the following example, we are attempting to configure interface gigabitethernet 3/10 on a switch stack. The stack only consists of 2 physical switches — the range of valid interfaces for the stack is 0/1 — 0/26 and 1/1 — 1/26. Interface gigabitethernet 3/10 is not a valid interface for this switch stack.

Ip address command

If you run into this error while trying to configure an IP address on an interface, make a note of where the ‘^’ character appears. In the following example, the ‘^’ character appears at the beginning of the word «address».

The position of the ‘^’ character seems to indicate that the word address is not a valid keyword or parameter in the current command context. We confirm this by entering ‘?’ after the first word of the command as follows:

. .
arp Configure ARP features
dhcp Configure DHCP parameters for this interface
. .

The context sensitive help indicates that the ip address command is not a valid command in the current context. What could be the reason for this? The most likely reason is that we are on a Layer 2 switch attempting to configure an IP address on a Layer 2 interface. IP addresses can only be configured on Layer 3 interfaces.

Invalid input detected at marker cisco что это

Cisco: Конфигурация и команды управления IOS

Регистрация (вход) в маршрутизатор

После вывода сообщения о статусе интерфейсов и нажатия клавиши Return появится приглашение Router>. Это приглашение пользовательского режима (user mode), которое часто используется для просмотра статистики, хотя из него можно перейти в привилегированный режим (privileged mode). В пользовательском режиме допускается только просмотр, а изменение конфигурации маршрутизатора Cisco выполняется в привилегированном режиме, переход в который выполняется командой enable.

Теперь приглашение имеет вид Router#, что отмечает привилегированный режим. В нем можно просматривать и изменять конфигурацию. Для выхода из привилегированного режима в пользовательский используйте команду disable .

Теперь можно ввести logout, чтобы выйти из режима консоли.

Router con0 is now available

( маршрутизатор con0 доступен )

Press RETURN to get started.

(для начала работы нажмите RETURN)

Либо разрешен ввод logout или exit в привилегированном режиме для вывода приглашения на выход.

Router con0 is now available

Press RETURN to get started.

Обзор режимов маршрутизатора

Для настройки из интерфейса CLI необходимо глобально изменить состояние маршрутизатора, указав команду config terminal (краткая форма:config t), которая переводит устройство в режим глобального конфигурирования и изменяет исполняемую конфигурацию running-config. Можно ввести config в приглашении привилегированного режима, а затем нажать Return для возвращения режима терминала по умолчанию.

Configuring from terminal, memory, or network [terminal]?return (настройка с терминала, из памяти или по сети)

Enter configuration commands, one per line. End with CNTL/Z. (введите команды конфигурирования, по одной в строке. Закончите ввод клавиатурной комбинацией CNTL/Z)

После этого можно внести изменения, которые действуют на маршрутизатор в целом. Для изменения конфигурации running-config, которая является текущей исполняемой конфигурацией в динамической оперативной памяти DRAM (Dynamic RAM) следует использовать команду config terminal (config t). Для изменения конфигурации из NVRAM (конфигурации запуска startup-config) следует ввести команду config memory (config mem). Если необходимо изменить конфигурацию маршрутизатора, хранящуюся на хосте TFTP, применяйте команду config network (config net). Однако для точного и реального изменения конфигурации маршрутизатора, ее следует поместить в оперативную память RAM. Т.е. ввод config mem или config net приводит к замене текущей исполняемой конфигурации running-config на конфигурацию, хранящуюся в памяти NVRAM или на хосте TFTP.

Приглашения интерфейса CLI

Важно научиться различать приглашения во время конфигурации маршрутизатора, чтобы точно знать текущий конфигурационный режим. В следующем разделе книги мы рассмотрим приглашения, выводимые маршрутизатором Cisco. Рекомендуется обращать внимание на выведенное приглашение перед любым изменением конфигурации маршрутизатора. Мы не стремимся сразу показать все доступные команды, но хотим на их примерах продемонстрировать различные приглашения, которые будут появляться и в других листингах.

Для изменения в интерфейсе служит команда interface в режиме глобального конфигурирования:

Router(config)#interface ? Async
Async interface
BVI Bridge-Group Virtual Interface
Dialer Dialer interface
FastEthernet FastEthernet IEEE 802.3
Group-Async Async Group interface
Lex Lex interface
Loopback Loopback interface
Multilink Multilink-group interface
Null Null interface
Port-channel Ethernet Channel of interfaces
Tunnel Tunnel interface
Virtual-Template Virtual Template interface
Virtual-TokenRing Virtual TokenRing

Router(config)#interface fastethernet 0/0

Заметьте , что приглашение изменилось на Router(config-if)#, что указывает на режим конфигурирования интерфейса. Было бы неплохо показать и настраиваемый интерфейс, но этого не сделано (наверное, поэтому администраторы Cisco зарабатывают больше, чем администраторы Windows).

Подинтерфейсы позволяют создавать в маршрутизаторе виртуальные интерфейсы. Приглашение меняется на Router(config-subif)#

Router(config)#int f 0 /0.?

FastEthernet interface number

Для настройки пароля пользовательского режима служит команда line. Приглашение становится Router (config-line)#.

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#line ?
First Line number
aux
Auxiliary line
console Primary terminal line
tty Terminal controller
vty Virtual terminal

Router(config)#line console 0

Команда line console 0 считается основной (глобальной) и любая введенная после нее команда называется подкомандой (иногда говорят, что подкоманды вводятся в приглашении config-line).

Настройка протокола маршрутизации

Для конфигурации протокола маршрутизации (например, RIP и IGRP) используется приглашение (config-router)# .

Enter configuration commands, one per line. End with CNTL/Z.

Важно понять, что делает каждая из команд в данное время. Об этом мы поговорим позже, а пока разберемся с другими доступными приглашениями.

Возможности редактирования и вывода справки

Расширенные возможности редактирования позволят упростить настройку маршрутизатора Cisco. Ввод вопросительного знака (?) в любом приглашении всегда выводит список доступных в этом приглашении команд (назначения каждой из показанных ниже команд см. в приложении С ).

Источник

If you make a mistake when entering a command in the CLI, or if the command is incomplete, you will get an error message like this

error messages meaning
% Ambiguous command. Can’t uniquely identify the command.
% Incomplete command. The command you entered is incomplete.
% Invalid input detected at “^” marker. The “^” is incorrect.
Table The main error messages in CLI

% Ambiguous command.

The error message “% Ambiguous command.” is displayed if the command cannot be uniquely identified. If you enter the command in an abbreviated form, you must enter it to the point where it is uniquely identified.

The following is an example of a “% Ambiguous command.” error message

R1#con t
% Ambiguous command:  "con t"

In this example, you would type “conf t” to enter global configuration mode, but you would type “con t” to enter global configuration mode. There are multiple commands that start with “con” and they cannot be uniquely identified. In such cases, the “% Ambiguous command.” will displayed

% Incomplete command.

The error message “% Incomplete command.” appears if you do not specify the required parameters for the command you entered. Make sure you know which parameters to provide.

The following is an example of a “% Incomplete command.” error message.

R1(config)#interface FastEthernet 0/0
R1(config-if)#ip address
% Incomplete command.

R1(config-if)#

The ip address command, which sets the IP address for an interface, requires you to specify the IP address and subnet mask. If you enter only the ip address, the parameters are incomplete. That’s why “% Incomplete command.” is displayed. To check the parameters you need, use the help.

% Invalid input detected at “^” marker.

The error message “% Invalid input detected at “^” marker.” is mainly shown when the command is misspelled. Make sure the command is spelled correctly.

The following is an example of “% Invalid input detected at “^” marker.

R1(config)#enable secrt cisco
                      ^
% Invalid input detected at '^' marker.

In this example, the “enable secret” command to set the password for privileged EXCE mode is spelled incorrectly. The wrong part is indicated by the “^” sign. You have misspelled “secret” as “secrt”.

To avoid misspelling commands, make use of command completion.

For CLI help and completion, see the following articles

Портал IT-специалистов: программирование, администрирование, базы данных

Сообщения об ошибках в Cisco CLI

При работе в консоли Cisco CLI вы можете увидеть три типа сообщений об ошибках:

  • Ambiguous command (Неоднозначная команда)
  • Incomplete command (Неполная команда)
  • Invalid input (Некорректный ввод)

Сообщение об ошибке

Смысл

Что делать?

% Ambiguous Command: “show con

Введено недостаточно символов, чтобы устройство могло распознать команду.

Повторно введите команду со знаком вопроса ( ?) сразу после последнего символа:

show con?

Будут отображены все возможные ключевые слова

% Incomplete Command

Для выполнения команды необходимо ввести дополнительные параметры.

Повторно введите команду со знаком вопроса ( ?). Поставьте пробел между командой и вопросительным знаком ( ?)

% Invalid input detected at ^ marker

Введенная команда содержит ошибку. Знак ^ отмечает место ошибки.

Повторно введите команду, исправив ошибку в месте расположения файла ^. Если вы не уверены, в чем заключается ошибка, повторно введите команду со знаком вопроса ( ?) в месте ошибки, чтобы отобразить доступные команды или параметры.

Вас заинтересует / Intresting for you:

OraCool аватар

apv аватар

apv ответил в теме #9992 1 год 9 мес. назад

Спасибо за шпаргалку, Андрей! Повторение — мать учения))

Ваш аккаунт

Разделы

Ошибка = % Invalid input detected at ‘^’ marker. = cisco packet tracer — циско пэкет трайсер

vedro-compota's picture

может возникнуть при «копипасте» — копировании (клик правой кнопкой мыши по консоли -> «вставить») комадны в консоль управления маршрутизатором.

если же набрать её самомстоятельно — то всё работает нормально —
у меня такая проблема наблюдалась с

На практике,правда, можно столкнуться и с такой ситуацией (решение в другом случае)

This message is not restricted to a particular CLI Mode or to a particular CLI command or task.

What does this error mean?

This error indicates that we have made an error while typing in a CLI command. This error message is preceded by a line with the single character ‘^’. There may be multiple errors in a line that we have typed in at the CLI. The ‘^’ indicates the first instance of an error in the line typed in.

For example, suppose we were attempting to configure an IP address on a router interface. We attempt to configure it as follows:

Looking at the command that we have typed in, we can see that we have misspelled the word «address». The ‘^’ under the letter ‘r’ in the word «address» informs us that there is an error at the letter ‘r’.

We can correct the error and type in the command again.

We have corrected the error in the word «address» but we notice that there is another error message. This time we notice that the ip address that we are trying to configure has an extra ‘.’ at the end. The ‘^’ indicates that there is an error at this location in the line that we have typed in.

We will re-enter the command without the extra ‘.’

This time the command is accepted with no warnings or error messages.

Point to note: There may be multiple errors in a line, but the ‘^’ character appears underneath the first error that is found. All of the errors are not highlighted at the same time.

A common occurence of this error with the «show» command

Take a look at the following example:

We are attempting to run the «show running-config» command. Why do we see an error message instead of the desired output?

Upon further inspection, we realize that we are currently in Global Configuration Mode (as indicated by the word ‘config’ in the CLI prompt). Most of the «show» commands are available in Privileged EXEC Mode (although a large number of them are also available in User EXEC Mode).

In this instance, if we want to see the running configration, we would need to either precede the command with the word «do», or exit back into Privileged EXEC Mode and run the «show run» command.

If we run into an «Invalid input detected at ‘^’ marker» error while attempting to run a «show» command we should always check to confirm that we are not in a Configuration Mode.

Remember : The «show running-config» and «show startup-config» commands are only available in Privileged EXEC Mode — they are not available in User EXEC Mode!

Other common occurences of this error

Interface command

If you run into this error while trying to enter the Interface Specific Configuraiton Mode using the interface command, it is possible that the interface label has been incorrectly typed in.

In the following example, the switch only has 26 gigabitethernet interfaces (0/1 to 0/26). We are attempting to configure interface gi 0/27. The ‘^’ character indicates that 0/27 is not a valid interface label.

In the following example, we are attempting to configure interface gigabitethernet 3/10 on a switch stack. The stack only consists of 2 physical switches — the range of valid interfaces for the stack is 0/1 — 0/26 and 1/1 — 1/26. Interface gigabitethernet 3/10 is not a valid interface for this switch stack.

Ip address command

If you run into this error while trying to configure an IP address on an interface, make a note of where the ‘^’ character appears. In the following example, the ‘^’ character appears at the beginning of the word «address».

The position of the ‘^’ character seems to indicate that the word address is not a valid keyword or parameter in the current command context. We confirm this by entering ‘?’ after the first word of the command as follows:

. . <output truncated>
arp Configure ARP features
dhcp Configure DHCP parameters for this interface
. . <output truncated>

The context sensitive help indicates that the ip address command is not a valid command in the current context. What could be the reason for this? The most likely reason is that we are on a Layer 2 switch attempting to configure an IP address on a Layer 2 interface. IP addresses can only be configured on Layer 3 interfaces.

Invalid input detected at marker cisco что это

Cisco: Конфигурация и команды управления IOS

Регистрация (вход) в маршрутизатор

После вывода сообщения о статусе интерфейсов и нажатия клавиши Return появится приглашение Router>. Это приглашение пользовательского режима (user mode), которое часто используется для просмотра статистики, хотя из него можно перейти в привилегированный режим (privileged mode). В пользовательском режиме допускается только просмотр, а изменение конфигурации маршрутизатора Cisco выполняется в привилегированном режиме, переход в который выполняется командой enable.

Теперь приглашение имеет вид Router#, что отмечает привилегированный режим. В нем можно просматривать и изменять конфигурацию. Для выхода из привилегированного режима в пользовательский используйте команду disable .

Теперь можно ввести logout, чтобы выйти из режима консоли.

Router con0 is now available

( маршрутизатор con0 доступен )

Press RETURN to get started.

(для начала работы нажмите RETURN)

Либо разрешен ввод logout или exit в привилегированном режиме для вывода приглашения на выход.

Router con0 is now available

Press RETURN to get started.

Обзор режимов маршрутизатора

Для настройки из интерфейса CLI необходимо глобально изменить состояние маршрутизатора, указав команду config terminal (краткая форма:config t), которая переводит устройство в режим глобального конфигурирования и изменяет исполняемую конфигурацию running-config. Можно ввести config в приглашении привилегированного режима, а затем нажать Return для возвращения режима терминала по умолчанию.

Configuring from terminal, memory, or network [terminal]?return (настройка с терминала, из памяти или по сети)

Enter configuration commands, one per line. End with CNTL/Z. (введите команды конфигурирования, по одной в строке. Закончите ввод клавиатурной комбинацией CNTL/Z)

После этого можно внести изменения, которые действуют на маршрутизатор в целом. Для изменения конфигурации running-config, которая является текущей исполняемой конфигурацией в динамической оперативной памяти DRAM (Dynamic RAM) следует использовать команду config terminal (config t). Для изменения конфигурации из NVRAM (конфигурации запуска startup-config) следует ввести команду config memory (config mem). Если необходимо изменить конфигурацию маршрутизатора, хранящуюся на хосте TFTP, применяйте команду config network (config net). Однако для точного и реального изменения конфигурации маршрутизатора, ее следует поместить в оперативную память RAM. Т.е. ввод config mem или config net приводит к замене текущей исполняемой конфигурации running-config на конфигурацию, хранящуюся в памяти NVRAM или на хосте TFTP.

Приглашения интерфейса CLI

Важно научиться различать приглашения во время конфигурации маршрутизатора, чтобы точно знать текущий конфигурационный режим. В следующем разделе книги мы рассмотрим приглашения, выводимые маршрутизатором Cisco. Рекомендуется обращать внимание на выведенное приглашение перед любым изменением конфигурации маршрутизатора. Мы не стремимся сразу показать все доступные команды, но хотим на их примерах продемонстрировать различные приглашения, которые будут появляться и в других листингах.

Для изменения в интерфейсе служит команда interface в режиме глобального конфигурирования:

Router(config)#interface ? Async
Async interface
BVI Bridge-Group Virtual Interface
Dialer Dialer interface
FastEthernet FastEthernet IEEE 802.3
Group-Async Async Group interface
Lex Lex interface
Loopback Loopback interface
Multilink Multilink-group interface
Null Null interface
Port-channel Ethernet Channel of interfaces
Tunnel Tunnel interface
Virtual-Template Virtual Template interface
Virtual-TokenRing Virtual TokenRing

Router(config)#interface fastethernet 0/0

Заметьте , что приглашение изменилось на Router(config-if)#, что указывает на режим конфигурирования интерфейса. Было бы неплохо показать и настраиваемый интерфейс, но этого не сделано (наверное, поэтому администраторы Cisco зарабатывают больше, чем администраторы Windows).

Подинтерфейсы позволяют создавать в маршрутизаторе виртуальные интерфейсы. Приглашение меняется на Router(config-subif)#

Router(config)#int f 0 /0.?

<0-4294967295> FastEthernet interface number

Для настройки пароля пользовательского режима служит команда line. Приглашение становится Router (config-line)#.

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#line ? <0-70>
First Line number
aux
Auxiliary line
console Primary terminal line
tty Terminal controller
vty Virtual terminal

Router(config)#line console 0

Команда line console 0 считается основной (глобальной) и любая введенная после нее команда называется подкомандой (иногда говорят, что подкоманды вводятся в приглашении config-line).

Настройка протокола маршрутизации

Для конфигурации протокола маршрутизации (например, RIP и IGRP) используется приглашение (config-router)# .

Enter configuration commands, one per line. End with CNTL/Z.

Важно понять, что делает каждая из команд в данное время. Об этом мы поговорим позже, а пока разберемся с другими доступными приглашениями.

Возможности редактирования и вывода справки

Расширенные возможности редактирования позволят упростить настройку маршрутизатора Cisco. Ввод вопросительного знака (?) в любом приглашении всегда выводит список доступных в этом приглашении команд (назначения каждой из показанных ниже команд см. в приложении С ).

Содержание

  1. ИТ База знаний
  2. Полезно
  3. Навигация
  4. Серверные решения
  5. Телефония
  6. Корпоративные сети
  7. Структура команд Cisco IOS
  8. Базовый курс по Asterisk
  9. Структура команд
  10. Контекстно-зависимая справка
  11. Горячие клавиши и сочетания клавиш
  12. Продвинутый курс по Asterisk
  13. Полезно?
  14. Почему?
  15. Cisco CLI Error: % Invalid input detected at ‘^’ marker
  16. In what CLI Mode does this error appear?
  17. What does this error mean?
  18. A common occurence of this error with the «show» command
  19. Other common occurences of this error
  20. Interface command
  21. Ip address command
  22. Support
  23. Using the Command-Line Interface
  24. Hierarchical Navigation
  25. Viewing Options
  26. Using the Command-Line Interface
  27. Information About Using the Command-Line Interface
  28. Command Modes

ИТ База знаний

Курс по Asterisk

Полезно

— Узнать IP — адрес компьютера в интернете

— Онлайн генератор устойчивых паролей

— Онлайн калькулятор подсетей

— Калькулятор инсталляции IP — АТС Asterisk

— Руководство администратора FreePBX на русском языке

— Руководство администратора Cisco UCM/CME на русском языке

— Руководство администратора по Linux/Unix

Навигация

Серверные решения

Телефония

FreePBX и Asterisk

Настройка программных телефонов

Корпоративные сети

Протоколы и стандарты

Структура команд Cisco IOS

Как и куда печатать?

Всем привет! Мы продолжаем знакомиться с операционной системой Cisco IOS. Недавно в статьях мы уже рассмотрели операционную систему Cisco IOSи ее режимы. В этой статье мы рассмотрим основную структуру команд Cisco IOS.

Базовый курс по Asterisk

Мы собрали концентрат всех must have знаний в одном месте, которые позволяют тебе сделать шаг вперед на пути к экспертному владению Asterisk

Структура команд

Устройства, работающие на Cisco IOS, поддерживают множество команд, каждая из которых имеет определенный формат или синтаксис и может быть выполнена только в соответствующем режиме. Общий синтаксис команды — это команда, за которой следуют любые подходящие ключевые слова и аргументы. Некоторые команды включают подмножество ключевых слов и аргументов, которые обеспечивают дополнительную функциональность. Команды используются для выполнения действия, а ключевые слова используются для идентификации.

Команда представляет собой начальное слово или слова, введенные в командной строке. Команды не чувствительны к регистру. После каждой введенной команды, включая любые ключевые слова и аргументы, нужно нажать Enter, чтобы отправить команду командному интерпретатору.

Ключевые слова описывают конкретные параметры командного интерпретатора. Например, команда show используется для отображения информации об устройстве. Эта команда имеет различные ключевые слова, которые должны использоваться для определения того, какой конкретный вывод должен отображаться.

За командой show следует ключевое слово running-config, которое указывает, что текущая конфигурация должна отображаться в качестве вывода.

Для команды может потребоваться один или несколько аргументов. В отличие от ключевого слова, аргумент обычно не является предопределенным словом. Аргумент — это значение или переменная, определяемая пользователем.

Контекстно-зависимая справка

Контекстно-зависимая справка содержит список команд и аргументов, связанных с этими командами в контексте текущего режима. Чтобы получить доступ к контекстно-зависимой справке, нужно ввести знак вопроса “?” в любом меню. Результат появится сразу, даже без нажатия клавиши Enter.

Одна из методов использования контекстно-зависимой справки — это получение списка доступных команд. Это можно использовать, если вы не уверены как правильно пишется команда или хотите увидеть, поддерживает ли IOS определенную команду в определенном режиме. Например, чтобы отобразить команды, доступные на уровне User EXEC, нужно ввести знак вопроса “?”, в меню Switch.

Другое использование контекстно-зависимой справки — отображать список команд или ключевых слов, которые начинаются с определенного символа или символов. После ввода последовательности символов, если знак вопроса сразу вводится без пробела, IOS отобразит список команд или ключевых слов для этого контекста, которые начинаются с введенных символов. Например, можно ввести sh? для получения списка команд, начинающихся с sh.

И еще один тип контекстно-зависимой справки используется для определения того, какие параметры, ключевые слова или аргументы сопоставляются с определенной командой. При вводе команды введите пробел, за которым следует символ “?” определить, что может или должно быть введено дальше.

Проверка синтаксиса команд

Когда команда отправляется нажатием клавиши Enter, интерпретатор командной строки анализирует команду слева направо, чтобы определить, какое действие запрашивается. Обычно IOS обеспечивает только отрицательную обратную связь, если что-то было введено неверно. Если интерпретатор не может понять введенную команду, он предоставит информацию о том, что не так с командой.

Двойственная команда (Ambiguous command) – введено недостаточно символов для, чтобы система распознала команду.

Неполная команда (Incomplete command) – не все необходимые ключевые слова или аргументы были введены.

Неверная команда (Invalid input) – команда введена некорректно. Ошибка произошла в месте, на которое указывает маркер

Горячие клавиши и сочетания клавиш

В CLI IOS есть возможность использовать горячие клавиши и сочетания клавиш, которые облегчают использование системы. Рассмотрим наиболее полезные из них:

  • Стрелка вниз — позволяет прокручивать строку вперед по введенным командам
  • Стрелка вверх – Позволяет прокручивать строку назад по введенным командам
  • Tab — завершает оставшуюся часть частично введенной команды или ключевого слова
  • Ctrl-A — переход к началу строки
  • Ctrl-E — перемещение в конец строки
  • Ctrl-R – повторное отображение строки
  • Ctrl-Z — Выход из режима конфигурации и возврат к User EXEC
  • Ctrl-C — выход из режима конфигурации или прерывание текущей команды
  • Ctrl-Shift-6 — Позволяет пользователю прерывать процесс IOS, такой как ping или traceroute

Рассмотрим их подробнее.

Клавиша Tab используется для завершения оставшейся части сокращенной команды и параметра, если аббревиатура содержит достаточно букв, чтобы отличаться от любых других доступных в данный момент команд или параметров. Когда для ввода уникальной команды или ключевого слова было введено достаточно символов, нужно нажать Tab, и CLI отобразит остальную часть команды или ключевого слова.

Повторное отображение строки обновит только что напечатанную строку. Например, IOS может отобразить сообщение в CLI во время набора команды пользователем. Ctrl-R можно использовать для обновления строки и избегать повторного ее ввода.

Выход из режима конфигурации выйдет из любого режима конфигурации и вернется в привилегированный режим EXEC. Поскольку IOS имеет иерархическую структуру, вместо того, чтобы выходить из каждого подрежима отдельно, можно использовать Ctrl-Z, привилегированный режим EXEC.

Стрелки вверх и вниз

При помощи стрелок можно отображать историю введенных команд. Cisco IOS выполняет буферизацию нескольких прошлых команд и символов, чтобы записи могли быть снова отображены. Буфер полезен для повторного ввода команд без повторного набора.

Эта последовательность прерывает любой выполняющийся процесс. Когда процесс IOS инициируется из CLI, например, ping или traceroute, команда работает до тех пор, пока не будет завершена или не будет прервана. Пока процесс выполняется, CLI не отвечает. Чтобы прервать вывод и взаимодействовать с CLI, нужно нажать Ctrl-Shift-6.

Прерывает ввод команды и выходит из режима конфигурации. Это может быть полезно после ввода команды, которая должна быть отменена.

Сокращенные команды или ключевые слова

Команды и ключевые слова могут быть сокращены до минимального количества символов, которые идентифицируют уникальный выбор. Например, команда configure может быть сокращена до conf, поскольку configure является единственной командой, которая начинается с conf. Аббревиатура con не будет работать, потому что более чем одна команда начинается с con. Ключевые слова также могут быть сокращены.

Продвинутый курс по Asterisk

Концентрат редких знаний, для внедрения Asterisk в крупных предприятиях, Все это мы собрали в одном курсе для тебя

Полезно?

Почему?

😪 Мы тщательно прорабатываем каждый фидбек и отвечаем по итогам анализа. Напишите, пожалуйста, как мы сможем улучшить эту статью.

😍 Полезные IT – статьи от экспертов раз в неделю у вас в почте. Укажите свою дату рождения и мы не забудем поздравить вас.

Источник

Cisco CLI Error: % Invalid input detected at ‘^’ marker

In what CLI Mode does this error appear?

This message is not restricted to a particular CLI Mode or to a particular CLI command or task.

What does this error mean?

This error indicates that we have made an error while typing in a CLI command. This error message is preceded by a line with the single character ‘^’. There may be multiple errors in a line that we have typed in at the CLI. The ‘^’ indicates the first instance of an error in the line typed in.

For example, suppose we were attempting to configure an IP address on a router interface. We attempt to configure it as follows:

Looking at the command that we have typed in, we can see that we have misspelled the word «address». The ‘^’ under the letter ‘r’ in the word «address» informs us that there is an error at the letter ‘r’.

We can correct the error and type in the command again.

We have corrected the error in the word «address» but we notice that there is another error message. This time we notice that the ip address that we are trying to configure has an extra ‘.’ at the end. The ‘^’ indicates that there is an error at this location in the line that we have typed in.

We will re-enter the command without the extra ‘.’

This time the command is accepted with no warnings or error messages.

Point to note: There may be multiple errors in a line, but the ‘^’ character appears underneath the first error that is found. All of the errors are not highlighted at the same time.

A common occurence of this error with the «show» command

Take a look at the following example:

We are attempting to run the «show running-config» command. Why do we see an error message instead of the desired output?

Upon further inspection, we realize that we are currently in Global Configuration Mode (as indicated by the word ‘config’ in the CLI prompt). Most of the «show» commands are available in Privileged EXEC Mode (although a large number of them are also available in User EXEC Mode).

In this instance, if we want to see the running configration, we would need to either precede the command with the word «do», or exit back into Privileged EXEC Mode and run the «show run» command.

If we run into an «Invalid input detected at ‘^’ marker» error while attempting to run a «show» command we should always check to confirm that we are not in a Configuration Mode.

Remember : The «show running-config» and «show startup-config» commands are only available in Privileged EXEC Mode — they are not available in User EXEC Mode!

Other common occurences of this error

Interface command

If you run into this error while trying to enter the Interface Specific Configuraiton Mode using the interface command, it is possible that the interface label has been incorrectly typed in.

In the following example, the switch only has 26 gigabitethernet interfaces (0/1 to 0/26). We are attempting to configure interface gi 0/27. The ‘^’ character indicates that 0/27 is not a valid interface label.

In the following example, we are attempting to configure interface gigabitethernet 3/10 on a switch stack. The stack only consists of 2 physical switches — the range of valid interfaces for the stack is 0/1 — 0/26 and 1/1 — 1/26. Interface gigabitethernet 3/10 is not a valid interface for this switch stack.

Ip address command

If you run into this error while trying to configure an IP address on an interface, make a note of where the ‘^’ character appears. In the following example, the ‘^’ character appears at the beginning of the word «address».

The position of the ‘^’ character seems to indicate that the word address is not a valid keyword or parameter in the current command context. We confirm this by entering ‘?’ after the first word of the command as follows:

. .
arp Configure ARP features
dhcp Configure DHCP parameters for this interface
. .

The context sensitive help indicates that the ip address command is not a valid command in the current context. What could be the reason for this? The most likely reason is that we are on a Layer 2 switch attempting to configure an IP address on a Layer 2 interface. IP addresses can only be configured on Layer 3 interfaces.

Want to test your networking skills with hands-on configuration and troubleshooting questions? Try out the free Workshops section of this website here: Workshops (Login required).

Read how to use the device simulators on this website here: Workshops — General Instructions

Источник

Support

Using the Command-Line Interface

Hierarchical Navigation

Viewing Options

Using the Command-Line Interface

Information About Using the Command-Line Interface

Command Modes

The Cisco IOS user interface is divided into many different modes. The commands available to you depend on which mode you are currently in. Enter a question mark (?) at the system prompt to obtain a list of commands available for each command mode.

You can start a CLI session through a console connection, through Telnet, a SSH, or by using the browser.

When you start a session, you begin in user mode, often called user EXEC mode. Only a limited subset of the commands are available in user EXEC mode. For example, most of the user EXEC commands are one-time commands, such as show commands, which show the current configuration status, and clear commands, which clear counters or interfaces. The user EXEC commands are not saved when the switch reboots.

To have access to all commands, you must enter privileged EXEC mode. Normally, you must enter a password to enter privileged EXEC mode. From this mode, you can enter any privileged EXEC command or enter global configuration mode.

Using the configuration modes (global, interface, and line), you can make changes to the running configuration. If you save the configuration, these commands are stored and used when the switch reboots. To access the various configuration modes, you must start at global configuration mode. From global configuration mode, you can enter interface configuration mode and line configuration mode.

This table describes the main command modes, how to access each one, the prompt you see in that mode, and how to exit the mode.

Источник

Introduction

This document answers the most Frequently Asked Questions (FAQs) related to Secure Shell (SSH). Cisco IOS® SSH code is Cisco original code. 

How do I configure SSH terminal-line access (also known as reverse-telnet)?

This was first introduced in some platforms of Cisco IOS Software Release 12.2.2.T.



Router(config)#line line-number [ending-line-number] 
Router(config-line)#no exec 
Router(config-line)#login {local | authentication listname 
Router(config-line)#rotary group 
Router(config-line)#transport input {all | ssh} 
Router(config-line)#exit 
Router(config)#ip ssh port portnum rotary group 


!--- Line 1 SSH Port Number 2001

line 1
   no exec
   login authentication default
   rotary 1
   transport input ssh

!--- Line 2 SSH Port Number 2002

line 2
   no exec
   login authentication default
   rotary 2
   transport input ssh

!--- Line 3 SSH Port Number 2003

line 3
   no exec
   login authentication default
   rotary 3
   transport input ssh
 
ip ssh port 2001 rotary 1 3

Command Reference

ip ssh port
	ip ssh port portnum rotary group

	no ip ssh port portnum rotary group

  • portnum — Specifies the port to which SSH needs to connect, such as 2001.

  • rotary group — Specifies the defined rotary that needs to search for a valid name.

Is SSH supported on the Catalyst 2900?

No, it is not.

How can I determine which platforms and versions of code support SSH?

See the Feature Navigator ( registered customers only) and specify the SSH feature.

When I try to remove certain SSH commands from my router, it continues to ask me to create RSA keys in order to enable SSH. Why is this?

An example of this problem is shown here:

804#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
804(config)#no ip ssh time-out 120
Please create RSA keys to enable SSH.
804(config)#no ip ssh authen
Please create RSA keys to enable SSH.
804(config)

You have encountered Cisco bug ID CSCdv70159 ( registered customers only) .

Does Cisco IOS SSH version 2 support Digital Signature Standard (DSS)?

Cisco IOS SSH version 2 does not support DSS.

Does the Cisco IOS SSH server support agent forwarding?

Cisco IOS SSH does not support agent forwarding. It interoperates with all the commercial SSH implementations.

What client authentication mechanisms are supported on the Cisco IOS SSH server?

Cisco IOS SSH version 2 (SSHv2) supports keyboard-interactive and password-based authentication methods. In addition to these authentication methods, the SSHv2 Enhancements for RSA Keys feature (available in Cisco IOS Software Release 15.0(1)M and later) supports RSA-based public key authentication for the client and server. For additional information on the authentication mechanisms supported by the Cisco IOS SSH server, refer to Secure Shell Version 2 Support.

What does the error Local: Corrupted check bytes on input mean?

Corrupted checkbytes means the SSH packet received failed its integrity check. This is usually because of incorrect decryption. This is also because of an incorrect key used. The incorrect key is caused by the dropping of an encrypted SSH packet. You have either dropped an encrypted packet which should have been sent or dropped a received encrypted packet which should have been decrypted.

Does Cisco IOS support SSH with Blowfish cipher?

Cisco IOS does not support SSH with Blowfish cipher. When an SSH client sends such unsupported cipher, the router displays debug messages mentioned in SSH Client Sends Unsupported (Blowfish) Cipher.

When I try to generate RSA keys for SSH access on a router using the crypto key generate rsa command in config mode, I receive this error: % Invalid input detected at ‘^’ marker.. It does not let the router generate the RSA keys to enable SSH access for the router. How is this error resolved?

This error appears when the image used on the router does not support the crypto key generate rsa command. This command is supported only in security images. In order to resolve this error use the security image of the appropriate series of the Cisco IOS router used.

Do Crypto images support Strong cipher to use SSH with ciphers such as 3DES or AES?

Yes. Only Crypto images support Strong cipher. In order to use SSH with ciphers such as 3DES or AES you must have Crypto images on your Cisco device.

These messages are seen in the logs when I try to configure SSH on a router: SSH2 13: RSA_sign: private key not found and SSH2 13: signature creation failed, status -1. How is this resolved?

These log messages are seen due to Cisco bug IDs CSCsa83601 ( registered customers only) and CSCtc41114 ( registered customers only). Refer to these bugs for more information.

Related Information

  • SSH Support Page
  • Technical Support & Documentation — Cisco Systems

40 / 31 / 11

Регистрация: 25.07.2014

Сообщений: 712

1

23.04.2022, 18:43. Показов 1001. Ответов 18


Доброго времени суток форумчане!
Пытаюсь настроить ssh на 2950 но получаю маркер ошибки

Код

RT-2(config)#crypto key generate rsa
              ^
% Invalid input detected at '^' marker.

настраиваю так

Код

RT-2(config)# crypto key generate rsa
RT-2(config)# line vty 0 15
RT-2(config)# transport preferred none
RT-2(config)# transport input ssh
RT-2(config)#transport output ssh

вот сам конфиг

Кликните здесь для просмотра всего текста

Код

RT-2#show run
Building configuration...

Current configuration : 4518 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname RT-2
!
enable password 7 14141B180F0B
!
ip subnet-zero
no ip domain-lookup
ip domain-name RT-2
!

shutdown vlan 10

!
spanning-tree extend system-id
!
!
interface FastEthernet0/1
 description not_used
 switchport access vlan 10
 switchport mode access
 switchport nonegotiate
 no ip address
 shutdown
 no cdp enable
!
interface FastEthernet0/2
 description not_used
 switchport access vlan 10
 switchport mode access
 switchport nonegotiate
 no ip address
 shutdown
 no cdp enable
!
interface FastEthernet0/3
 description not_used
 switchport access vlan 10
 switchport mode access
 switchport nonegotiate
 no ip address
 shutdown
 no cdp enable
!
interface FastEthernet0/4
 description not_used
 switchport access vlan 10
 switchport mode access
 switchport nonegotiate
 no ip address
 shutdown
 no cdp enable
!
interface FastEthernet0/5
 description not_used
 switchport access vlan 10
 switchport mode access
 switchport nonegotiate
 no ip address
 shutdown
 no cdp enable
!
interface FastEthernet0/6
 description not_used
 switchport access vlan 10
 switchport mode access
 switchport nonegotiate
 no ip address
 shutdown
 no cdp enable
!
interface FastEthernet0/7
 description not_used
 switchport access vlan 10
 switchport mode access
 switchport nonegotiate
 no ip address
 shutdown
 no cdp enable
!
interface FastEthernet0/8
 description not_used
 switchport access vlan 10
 switchport mode access
 switchport nonegotiate
 no ip address
 shutdown
 no cdp enable
!
interface FastEthernet0/9
 description not_used
 switchport access vlan 10
 switchport mode access
 switchport nonegotiate
 no ip address
 shutdown
 no cdp enable
!
interface FastEthernet0/10
 description not_used
 switchport access vlan 10
 switchport mode access
 switchport nonegotiate
 no ip address
 shutdown
 no cdp enable
!
interface FastEthernet0/11
 description not_used
 switchport access vlan 10
 switchport mode access
 switchport nonegotiate
 no ip address
 shutdown
 no cdp enable
!
interface FastEthernet0/12
 description not_used
 switchport access vlan 10
 switchport mode access
 switchport nonegotiate
 no ip address
 shutdown
 no cdp enable
!
interface FastEthernet0/13
 description not_used
 switchport access vlan 10
 switchport mode access
 switchport nonegotiate
 no ip address
 shutdown
 no cdp enable
!
interface FastEthernet0/14
 description not_used
 switchport access vlan 10
 switchport mode access
 switchport nonegotiate
 no ip address
 shutdown
 no cdp enable
!
interface FastEthernet0/15
 description not_used
 switchport access vlan 10
 switchport mode access
 switchport nonegotiate
 no ip address
 shutdown
 no cdp enable
!
interface FastEthernet0/16
 description not_used
 switchport access vlan 10
 switchport mode access
 switchport nonegotiate
 no ip address
 shutdown
 no cdp enable
!
interface FastEthernet0/17
 description not_used
 switchport access vlan 10
 switchport mode access
 switchport nonegotiate
 no ip address
 shutdown
 no cdp enable
!
interface FastEthernet0/18
 description not_used
 switchport access vlan 10
 switchport mode access
 switchport nonegotiate
 no ip address
 shutdown
 no cdp enable
!
interface FastEthernet0/19
 description not_used
 switchport access vlan 10
 switchport mode access
 switchport nonegotiate
 no ip address
 shutdown
 no cdp enable
!
interface FastEthernet0/20
 description not_used
 switchport access vlan 10
 switchport mode access
 switchport nonegotiate
 no ip address
 shutdown
 no cdp enable
!
interface FastEthernet0/21
 description not_used
 switchport access vlan 10
 switchport mode access
 switchport nonegotiate
 no ip address
 shutdown
 no cdp enable
!
interface FastEthernet0/22
 description not_used
 switchport access vlan 10
 switchport mode access
 switchport nonegotiate
 no ip address
 shutdown
 no cdp enable
!
interface FastEthernet0/23
 description not_used
 switchport access vlan 10
 switchport mode access
 switchport nonegotiate
 no ip address
 shutdown
 no cdp enable
!
interface FastEthernet0/24
 description not_used
 switchport access vlan 10
 switchport mode access
 switchport nonegotiate
 no ip address
 shutdown
 no cdp enable
!
interface Vlan1
 ip address 192.168.0.11 255.255.255.0
 no ip route-cache
 shutdown
!
ip default-gateway 192.168.0.1
no ip http server
!
no cdp run
!
line con 0
line vty 0 4
 password 7 13061E010803
 login
line vty 5 15
 password 7 13061E010803
 login
!
end

Подскажите пожалуйста, что не так .

Добавлено через 25 минут
Конфиг подправил

Кликните здесь для просмотра всего текста

Код

RT-2#show ru
Building configuration...

Current configuration : 3606 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname RT-2
!
enable password 7 14141B180F0B
!
ip subnet-zero
no ip domain-lookup
ip domain-name RT-2
!

shutdown vlan 10

!
spanning-tree extend system-id
!
!
interface FastEthernet0/1
 switchport mode access
 no ip address
 shutdown
 speed 100
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/2
 switchport mode access
 no ip address
 shutdown
 speed 100
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/3
 switchport mode access
 no ip address
 shutdown
 speed 100
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/4
 switchport mode access
 no ip address
 shutdown
 speed 100
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/5
 switchport mode access
 no ip address
 shutdown
 speed 100
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/6
 switchport mode access
 no ip address
 shutdown
 speed 100
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/7
 switchport mode access
 no ip address
 shutdown
 speed 100
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/8
 switchport mode access
 no ip address
 shutdown
 speed 100
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/9
 switchport mode access
 no ip address
 shutdown
 speed 100
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/10
 switchport mode access
 no ip address
 shutdown
 speed 100
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/11
 switchport mode access
 no ip address
 shutdown
 speed 100
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/12
 switchport mode access
 no ip address
 shutdown
 speed 100
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/13
 switchport mode access
 no ip address
 shutdown
 speed 100
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/14
 switchport mode access
 no ip address
 shutdown
 speed 100
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/15
 switchport mode access
 no ip address
 shutdown
 speed 100
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/16
 switchport mode access
 no ip address
 shutdown
 speed 100
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/17
 switchport mode access
 no ip address
 shutdown
 speed 100
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/18
 switchport mode access
 no ip address
 shutdown
 speed 100
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/19
 switchport mode access
 no ip address
 shutdown
 speed 100
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/20
 switchport mode access
 no ip address
 shutdown
 speed 100
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/21
 switchport mode access
 no ip address
 shutdown
 speed 100
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/22
 switchport mode access
 no ip address
 shutdown
 speed 100
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/23
 switchport mode access
 no ip address
 shutdown
 speed 100
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/24
 switchport mode access
 no ip address
 shutdown
 speed 100
 no cdp enable
 spanning-tree portfast
!
interface Vlan1
 ip address 192.168.0.11 255.255.255.0
 no ip route-cache
 shutdown
!
ip default-gateway 192.168.0.1
no ip http server
!
no cdp run
!
line con 0
line vty 0 4
 password 7 13061E010803
 login
line vty 5 15
 password 7 13061E010803
 login
!
end

Результата не дало.

__________________
Помощь в написании контрольных, курсовых и дипломных работ, диссертаций здесь



0



Эксперт по компьютерным сетям

10929 / 6785 / 1814

Регистрация: 25.12.2012

Сообщений: 28,712

24.04.2022, 09:41

2

Так у вас пару ключей получилось сгенерить?



0



40 / 31 / 11

Регистрация: 25.07.2014

Сообщений: 712

24.04.2022, 18:26

 [ТС]

3

Цитата
Сообщение от insect_87
Посмотреть сообщение

Так у вас пару ключей получилось сгенерить?

Нет получаю ошибку

Код

RT-2(config)#crypto key generate rsa
              ^
% Invalid input detected at '^' marker.

либо так

Код

RT-2(config)#crypto key generate rsa modulus 1024
              ^
% Invalid input detected at '^' marker.

Может сама система не поддерживает

Кликните здесь для просмотра всего текста

Код

RT-2#sh version
Cisco Internetwork Operating System Software
IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(9)EA1, RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Wed 24-Apr-02 06:57 by antonino
Image text-base: 0x80010000, data-base: 0x804E8000

ROM: Bootstrap program is CALHOUN boot loader

RT-2 uptime is 16 minutes
System returned to ROM by power-on
System image file is "flash:c2950-i6q4l2-mz.121-9.EA1.bin"

cisco WS-C2950-24 (RC32300) processor (revision E0) with 20815K bytes of memory.
Processor board ID FOC0625W1Y3
Last reset from system-reset
Running Standard Image
24 FastEthernet/IEEE 802.3 interface(s)

32K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address: 00:0A:41:1F:16:40
Motherboard assembly number: 73-5781-10
Power supply part number: 34-0965-01
Motherboard serial number: FOC06250FHY
Power supply serial number: DAB06244UET
Model revision number: E0
Motherboard revision number: B0
Model number: WS-C2950-24
System serial number: FOC0625W1Y3
Configuration register is 0xF

Добавлено через 17 минут
Вот все мои действия после сброса в дефолт

Кликните здесь для просмотра всего текста

Код

Switch(config)# enable password cisco

Switch(config)# line vty 0 15
Switch(config-line)#password cisco
Switch(config-line)# login
Switch(config)# exit

Switch(config)# service password-encryption


Switch(config)# hostname RT-2


RT-2(config)# interface vlan 1
RT-2(config-if)# ip address 192.168.0.11 255.255.255.0
RT-2(config-if)# exit


RT-2(config)# no ip domain-lookup

RT-2(config)# ip domain-name RT-2

RT-2(config)# interface range Fa0/1 - 24
  switchport mode trunk
  switchport nonegotiate 
  speed 100
  load-interval 60
  spanning-tree portfast trunk


RT-2(config)# no ip http server

RT-2(config)# ip default-gateway 192.168.0.1

RT-2# wri

----------------ssh----------------
RT-2(config)# aaa new-model
RT-2(config)# access-list 23 permit 192.168.0.0 0.0.0.255
RT-2(config)# crypto key generate rsa modulus 1024
RT-2(config)# ip ssh version 2
RT-2(config)# username root secret cisco
RT-2(config)# line vty 0 4
RT-2(config-line)# login local
RT-2(config-line)# transport input ssh
RT-2(config-line)# logging synchronous
RT-2(config-line)# privilege level 15
RT-2(config-line)# exit
RT-2(config)# exit
RT-2# wri

Сейчас застопорился на ssh



0



Эксперт по компьютерным сетям

10929 / 6785 / 1814

Регистрация: 25.12.2012

Сообщений: 28,712

24.04.2022, 19:18

4



0



40 / 31 / 11

Регистрация: 25.07.2014

Сообщений: 712

24.04.2022, 19:33

 [ТС]

5

Код

RT-2#sh ver
Cisco Internetwork Operating System Software
IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(9)EA1, RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Wed 24-Apr-02 06:57 by antonino
Image text-base: 0x80010000, data-base: 0x804E8000

ROM: Bootstrap program is CALHOUN boot loader

RT-2 uptime is 0 minutes
System returned to ROM by power-on
System image file is "flash:c2950-i6q4l2-mz.121-9.EA1.bin"

cisco WS-C2950-24 (RC32300) processor (revision E0) with 20815K bytes of memory.
Processor board ID FOC0625W1Y3
Last reset from system-reset
Running Standard Image
24 FastEthernet/IEEE 802.3 interface(s)

32K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address: 00:0A:41:1F:16:40
Motherboard assembly number: 73-5781-10
Power supply part number: 34-0965-01
Motherboard serial number: FOC06250FHY
Power supply serial number: DAB06244UET
Model revision number: E0
Motherboard revision number: B0
Model number: WS-C2950-24
System serial number: FOC0625W1Y3
Configuration register is 0xF



0



Эксперт по компьютерным сетям

10929 / 6785 / 1814

Регистрация: 25.12.2012

Сообщений: 28,712

24.04.2022, 19:49

6

Может 2950 вообще не поддерживают ssh/шифрование
show ssh команды нет?



0



40 / 31 / 11

Регистрация: 25.07.2014

Сообщений: 712

24.04.2022, 19:55

 [ТС]

7

Код

RT-2#show ssh
           ^
% Invalid input detected at '^' marker.

Может есть возможность обновить ос



0



Эксперт по компьютерным сетям

10929 / 6785 / 1814

Регистрация: 25.12.2012

Сообщений: 28,712

24.04.2022, 20:16

8

Тогда не знаю, у меня из самых младших только 2960 были



0



40 / 31 / 11

Регистрация: 25.07.2014

Сообщений: 712

25.04.2022, 06:58

 [ТС]

9

Цитата
Сообщение от insect_87
Посмотреть сообщение

Может 2950 вообще не поддерживают ssh/шифрование

Вроде как у него нет
System image file is «flash:c2950-i6q4l2-mz.121-9.EA1.bin»
Информацию взял тут https://learningnetwork.cisco.com/s/question/0D53i00000KstiNCAR/cisco-2950-switch-ssh
Вот этот пост

To be able to configure ssh on 2950 switch, you should have the Enhanced Software Image» on your device. Please check out this link:

http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst2950/software/release/12-1_14_az/release/notes/OL480501.html#wp34681

но ссылка не работает, может вы сталкивались с установкой расширенного образа системы



0



Эксперт по компьютерным сетям

10929 / 6785 / 1814

Регистрация: 25.12.2012

Сообщений: 28,712

25.04.2022, 08:04

10

нет



0



40 / 31 / 11

Регистрация: 25.07.2014

Сообщений: 712

25.04.2022, 17:22

 [ТС]

11

Попробовал прошить, вроде все в порядке ssh поднялся

Код

RT-2#sh conf
Using 1491 out of 32768 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname RT-2
!
aaa new-model
enable password 7 070C285F4D06
!
username root secret 5 $1$t6hm$hQz4hqzEay9nupvY.gBSe.
ip subnet-zero
!
no ip domain-lookup
ip domain-name RT-2
ip ssh time-out 120
ip ssh authentication-retries 3
ip ssh version 2
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
 ip address 192.168.0.11 255.255.255.0
 no ip route-cache
!
ip default-gateway 192.168.0.1
no ip http server
access-list 23 permit 192.168.0.0 0.0.0.255
!
line con 0
line vty 0 4
 privilege level 15
 password 7 030752180500
 logging synchronous
 transport input ssh
line vty 5 15
 password 7 030752180500
!
!
end

Добавлено через 35 минут
При подготовки второго аппарата возникла проблема, не могу вывести с shutdown

Код

RT-1(config)#interface range FastEthernet0/1 - 12
RT-1(config-if-range)#no  shutdown

не работает

Вот весь конфиг, подскажите мот что то я не так сделал

Кликните здесь для просмотра всего текста

Код

RT-1#sh conf
Using 1095 out of 32768 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname RT-1
!
enable password 7 14141B180F0B
!
username root privilege 15 password 7 045802150C2E
ip subnet-zero
!
no ip domain-lookup
ip domain-name RT-1
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
interface FastEthernet0/1
 shutdown
!
interface FastEthernet0/2
 shutdown
!
interface FastEthernet0/3
 shutdown
!
interface FastEthernet0/4
 shutdown
!
interface FastEthernet0/5
 shutdown
!
interface FastEthernet0/6
 shutdown
!
interface FastEthernet0/7
 shutdown
!
interface FastEthernet0/8
 shutdown
!
interface FastEthernet0/9
 shutdown
!
interface FastEthernet0/10
 shutdown
!
interface FastEthernet0/11
 shutdown
!
interface FastEthernet0/12
 shutdown
!
interface Vlan1
 ip address 192.168.0.12 255.255.255.0
 no ip route-cache
 shutdown
!
ip default-gateway 192.168.0.1
no ip http server
!
line con 0
line vty 0 4
 password 7 121A0C041104
 login
line vty 5 15
 password 7 045802150C2E
 login
!
!
end



0



Эксперт по компьютерным сетям

10929 / 6785 / 1814

Регистрация: 25.12.2012

Сообщений: 28,712

25.04.2022, 17:52

12

Да не, всё так.
Чудеса у вас там, перепрошейте и его



0



40 / 31 / 11

Регистрация: 25.07.2014

Сообщений: 712

25.04.2022, 18:57

 [ТС]

13

так вот по сети он не определяет сетевую карту мне необходимо чтоб был доступ в сеть

Добавлено через 38 минут
подскажите пожалуйста, возможно-ли прописать доступ в сеть с отдельного интерфейса
так не работает

Код

RT-2(config)# interface FastEthernet0/2 
no shutdown
ip address 192.168.0.13 255.255.255.0

попробовал транк прописался

Код

RT-2(config)# interface range Fa0/2
  switchport mode trunk
  switchport nonegotiate 
  speed 100
  load-interval 60
  spanning-tree portfast trunk

Кликните здесь для просмотра всего текста

Код

# sh conf
Using 1140 out of 32768 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname RT-1
!
enable password 7 13061E010803
!
ip subnet-zero
!
no ip domain-lookup
ip domain-name RT-1
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
interface FastEthernet0/1
 shutdown
!
interface FastEthernet0/2
 switchport mode trunk
 switchport nonegotiate
 load-interval 60
 shutdown
 speed 100
 spanning-tree portfast trunk
!
interface FastEthernet0/3
 shutdown
!
interface FastEthernet0/4
 shutdown
!
interface FastEthernet0/5
 shutdown
!
interface FastEthernet0/6
 shutdown
!
interface FastEthernet0/7
 shutdown
!
interface FastEthernet0/8
 shutdown
!
interface FastEthernet0/9
 shutdown
!
interface FastEthernet0/10
 shutdown
!
interface FastEthernet0/11
 shutdown
!
interface FastEthernet0/12
 shutdown
!
interface Vlan1
 ip address 192.168.0.12 255.255.255.0
 no ip route-cache
!
ip default-gateway 192.168.0.1
no ip http server
!
line con 0
line vty 0 4
 password 7 01100F175804
 login
line vty 5 15
 password 7 01100F175804
 login
!
!
end

Подскажите пожалуйста, что можно сделать чтоб дивайс увидел сеть (для заливки образа по tftp)

Добавлено через 12 минут
после сброса порты так же не поднимаются

Кликните здесь для просмотра всего текста

Код

Switch#sh conf
Using 867 out of 32768 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
!
ip subnet-zero
!
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
interface FastEthernet0/1
 shutdown
!
interface FastEthernet0/2
 shutdown
!
interface FastEthernet0/3
 shutdown
!
interface FastEthernet0/4
 shutdown
!
interface FastEthernet0/5
 shutdown
!
interface FastEthernet0/6
 shutdown
!
interface FastEthernet0/7
 shutdown
!
interface FastEthernet0/8
 shutdown
!
interface FastEthernet0/9
 shutdown
!
interface FastEthernet0/10
 shutdown
!
interface FastEthernet0/11
 shutdown
!
interface FastEthernet0/12
 shutdown
!
interface Vlan1
 ip address 192.168.0.12 255.255.255.0
 no ip route-cache
 shutdown
!
ip http server
!
line con 0
line vty 5 15
!
!
end



0



Эксперт по компьютерным сетям

10929 / 6785 / 1814

Регистрация: 25.12.2012

Сообщений: 28,712

25.04.2022, 20:23

14

Подскажите пожалуйста, что можно сделать чтоб дивайс увидел сеть (для заливки образа по tftp)

Так по tftp не получится, у вас же порты не стартуют, выключены…



0



40 / 31 / 11

Регистрация: 25.07.2014

Сообщений: 712

26.04.2022, 06:07

 [ТС]

15

Цитата
Сообщение от insect_87
Посмотреть сообщение

Так по tftp не получится, у вас же порты не стартуют, выключены…

да вот в этом и вся проблема, получается только программатором шить флешку.



0



Эксперт по компьютерным сетям

10929 / 6785 / 1814

Регистрация: 25.12.2012

Сообщений: 28,712

26.04.2022, 09:46

16



0



40 / 31 / 11

Регистрация: 25.07.2014

Сообщений: 712

26.04.2022, 09:54

 [ТС]

17

Отлично! Спасибо! Вечером попробую



0



40 / 31 / 11

Регистрация: 25.07.2014

Сообщений: 712

26.04.2022, 17:58

 [ТС]

18

Залил прошивку, поднялся ssh. Проблема с портами осталась.

Кликните здесь для просмотра всего текста

Код

#sh ver
Cisco Internetwork Operating System Software
IOS (tm) C2950 Software (C2950-I6K2L2Q4-M), Version 12.1(22)EA14, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2010 by cisco Systems, Inc.
Compiled Tue 26-Oct-10 10:35 by nburra
Image text-base: 0x80010000, data-base: 0x80680000

ROM: Bootstrap program is C2950 boot loader

RT-1 uptime is 0 minutes
System returned to ROM by power-on
System image file is "flash:/c2950-i6k2l2q4-mz.121-22.EA14.bin"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

cisco WS-C2950-12 (RC32300) processor (revision C0) with 19911K bytes of memory.
Processor board ID FOC0620Z2CD
Last reset from system-reset
Running Standard Image

32K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address: 00:09:B7:AF:F4:00
Motherboard assembly number: 73-5782-10
Power supply part number: 34-0965-01
Motherboard serial number: FOC06200E35
Power supply serial number: PHI061606A8
Model revision number: C0
Motherboard revision number: A0
Model number: WS-C2950-12
System serial number: FOC0620Z2CD
Configuration register is 0xF

Проблема с shutdown осталась

Кликните здесь для просмотра всего текста

Код

#sh conf
Using 1273 out of 32768 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname RT-1
!
aaa new-model
enable password 7 1511021F0725
!
username root secret 5 $1$MhD8$RsHY/se7BMpqf/ZGsvtin1
ip subnet-zero
!
no ip domain-lookup
ip domain-name RT-1
ip ssh time-out 120
ip ssh authentication-retries 3
ip ssh version 2
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
interface FastEthernet0/1
 shutdown
!
interface FastEthernet0/2
 shutdown
!
interface FastEthernet0/3
 shutdown
!
interface FastEthernet0/4
 shutdown
!
interface FastEthernet0/5
 shutdown
!
interface FastEthernet0/6
 shutdown
!
interface FastEthernet0/7
 shutdown
!
interface FastEthernet0/8
 shutdown
!
interface FastEthernet0/9
 shutdown
!
interface FastEthernet0/10
 shutdown
!
interface FastEthernet0/11
 shutdown
!
interface FastEthernet0/12
 shutdown
!
interface Vlan1
 ip address 192.168.0.12 255.255.255.0
 no ip route-cache
 shutdown
!
ip default-gateway 192.168.0.1
no ip http server
access-list 23 permit 192.168.0.0 0.0.0.255
!
line con 0
line vty 0 4
 privilege level 15
 password 7 045802150C2E
 logging synchronous
 transport input ssh
line vty 5 15
 password 7 00071A150754
!
!
end

индикаторы оранжевые на всех портах.
При рестарте горит зеленый индикатор на подключенном порте но при полной загрузки опять все оранжевые



0



Эксперт по компьютерным сетям

10929 / 6785 / 1814

Регистрация: 25.12.2012

Сообщений: 28,712

26.04.2022, 19:02

19

Может уже аппаратная трабла?



0



Понравилась статья? Поделить с друзьями:
  • Cisco channel misconfig error
  • Cisco authentication failed как исправить
  • Cisco asr error overrun
  • Cisco anyconnect ошибка подключения
  • Cisco 3750 error loading flash