Contents
Introduction
This document provides explanations of service configuration errors encountered during initial hardware bootup when you run Cisco IOS® software.
Prerequisites
Requirements
There are no specific requirements for this document.
Components Used
This document is not restricted to specific software and hardware versions.
The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.
Conventions
Refer to Cisco Technical Tips Conventions for more information on document conventions.
Problem: Service Configuration Error Messages
Occasionally, during bootup of Cisco hardware through Cisco IOS software, error messages similar to these are displayed:
-
%Error opening tftp://255.255.255.255/network-confg (Socket error)
-
%Error opening tftp://255.255.255.255/cisconet.cfg (Socket error)
-
%Error opening tftp://255.255.255.255/3620-confg (Socket error)
-
%Error opening tftp://255.255.255.255/3620.cfg (Socket error)
These error messages are related to the default service configuration option built into Cisco IOS software, which attempts to access the service configuration files from a network Trivial File Transfer Protocol (TFTP) server.
Solution
In order to disable this feature, issue the no service config global command.
Router#config terminal Enter configuration commands, one per line. Router(config)#no service config Router(config)#exit Router#copy running-config startup-config
These error messages no longer appear at the next bootup of the router.
Related Information
- Technical Support & Documentation — Cisco Systems
Fermé
tseetsix
Messages postés
36
Date d’inscription
mercredi 11 novembre 2015
Statut
Membre
Dernière intervention
7 juin 2016
—
3 déc. 2015 à 10:05
tseetsix —
14 déc. 2015 à 08:18
Bonjour,
J’ai mis à jour mon routeur C800 séries avec tftp32,et j’ai reçu cet message d’erreur: «%Error opening tftp://192.168.1.229/c850-advsecurityk9-mz.124-6.T5.bin (No such file or directory) »
IP PC:192.168.1.229
IP ROUTEUR:192.168.1.254
Regarde l’image:ping OK avec vlan(car IPaddresses may not be configured on L2 links)
A voir également:
-
Error opening tftp timed out
-
No tftp response
✓
—
Forum Mobile
-
Fan error lenovo
✓
—
Forum Refroidissement
-
Error 522
✓
—
Forum Virus / Sécurité
-
Cpu fan error
✓
—
Forum Processeur
-
LENOVO fan error au démarrage
—
Forum Refroidissement
tseetsix
Messages postés
36
Date d’inscription
mercredi 11 novembre 2015
Statut
Membre
Dernière intervention
7 juin 2016
3 déc. 2015 à 13:18
Router>
Router>
Router>
Router>en
Password:
Router#sh run
Building configuration…
Current configuration : 855 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$bAf.$VqENcr2977Ka4Fmy/8xg2.
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
!
ip cef
!
!
!
!
!
!
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
no ip address
shutdown
duplex auto
speed auto
!
interface Vlan1
ip address 192.168.1.230 255.255.255.0
!
ip default-gateway 192.168.1.229
ip classless
!
no ip http server
no ip http secure-server
!
!
control-plane
!
banner login ^CBy Tseetsix^C
banner motd ^CMbola atao mise a jour ny IOS^C
!
line con 0
password admin
no modem enable
line aux 0
line vty 0 4
login
!
scheduler max-task-time 5000
end
Router#
Router#
Router#
Router#
Router#
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#no service config
Router(config)#do wr
Building configuration…
[OK]
Router(config)#exit
Router#
- Mar 13 02:16:29.775: %SYS-5-CONFIG_I: Configured from console by console
Router#copy tftp flash
Address or name of remote host []? 192.168.1.229
Source filename []? c850-advsecurityk9-mz.124-4.T7.bin
Destination filename [c850-advsecurityk9-mz.124-4.T7.bin]?
Accessing tftp://192.168.1.229/c850-advsecurityk9-mz.124-4.T7.bin…
%Error opening tftp://192.168.1.229/c850-advsecurityk9-mz.124-4.T7.bin (No such file or directory)
Router#
Discussions similaires
Booting the Router Using a Remote Configuration File
Problem
You want to boot the router using an alternate
configuration.
Solution
The following set of commands allows you to automatically load a
configuration file located on a remote TFTP server when the router boots:
Router1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z. Router1(config)#service config
Router1(config)#boot network tftp
Router1(config)#
Network-auto 172.25.1.1
boot host tftp
Router1(config)#
Router8-auto 172.25.1.1
end
Router1#
Discussion
By default, when the router reloads, it will read the
configuration information from a file in its Nonvolatile Random Access
Memory (NVRAM). Cisco commonly refers to this file as the startup configuration file. However, you can configure
the router to load all or part of its configuration from a remote
server via TFTP. This feature does not prevent the router from loading
its startup configuration from NVRAM. In fact, the router will load
its local startup file first before proceeding to the TFTP server
files.
Uses for this feature vary, although most people who implement
it do so because their configuration file has grown too large for
their NVRAM to handle. It can also be a useful way of keeping an
access-list that is shared by a number of routers, centralized and up
to date. And we have sometimes used it as a temporary measure when the
NVRAM in a router is damaged.
However, we consider this feature to be highly risky and
recommend avoiding it in most cases. If the problem is simply one of
NVRAM capacity, Recipe 1.4
shows how to compress the startup configuration file to help fit more
information into your existing NVRAM. Also, since routers can operate
for years without reloading, using this feature to keep your routers
up to date seems pointless.
If you choose to implement remote configuration despite these
cautions, we should mention a few other items. First, the router will
attempt to load a host and a network file. The router will assume that
network files are common to all routers, while the host files contain
router specific information. When you enable the service config option, the router will
attempt to first load a network file and then a host file. If it can’t
find these files, the router will generate error messages:
%Error opening tftp://255.255.255.255/network-confg (Timed out) %Error opening tftp://255.255.255.255/cisconet.cfg (Timed out) %Error opening tftp://255.255.255.255/router1-confg (Timed out) %Error opening tftp://255.255.255.255/router1.cfg (Timed out)
Here you can see what happened when we enabled the service config option and reloaded our
router, which was called router1
.
It attempted to load several different files automatically. The first
two files have generic network filenames. Then it looks for the host
file under two different names. The router attempts to load these
configuration files from IP address 255.255.255.255
by default.
Then, when we added the boot commands, the router looks for the
specified files from the appropriate TFTP server. Again, notice the
order in which the router loaded the files, with the network file
first followed by the host file:
Loading Network-auto from 172.25.1.1 (via Ethernet0): ! [OK - 27/4096 bytes] Loading Router8-auto from 172.25.1.1 (via Ethernet0): ! [OK - 71/4096 bytes]
If you do not configure the router to load specific network or
host filenames, it will try to load the default files, shown in the
trace above. If these files don’t exist, the router will pause for a
significant amount of time while it tries to find them. So when you
use this feature, you should always include both a network and a host
file to load. If you don’t need a network file, for example, you can
put a file on the server that only contains the keyword “end”.
This feature only loads configuration commands into the running
configuration. It does not copy them into the startup configuration
file.
The show version command tells you whether the
router was able to load these files successfully:
Router1#show version
Cisco Internetwork Operating System Software
IOS (tm) 2500 Software (C2500-IO-L), Version 12.2(7a), RELEASE SOFTWARE (fc2)
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Thu 21-Feb-02 02:07 by pwade
Image text-base: 0x0304CF80, data-base: 0x00001000
ROM: System Bootstrap, Version 5.2(8a), RELEASE SOFTWARE
BOOTLDR: 3000 Bootstrap Software (IGS-RXBOOT), Version 10.2(8a), RELEASE SOFTWAR
E (fc1)
Router1 uptime is 4 minutes
System returned to ROM by reload
System image file is "flash:c2500-io-l.122-7a.bin"
Host configuration file is "tftp://172.25.1.1/Router1-auto"
Network configuration file is "tftp://172.25.1.1/Network-auto"
cisco 2500 (68030) processor (revision D) with 16384K/2048K bytes of memory.
Processor board ID 04915359, with hardware revision 00000000
Bridging software.
X.25 software, Version 3.0.0.
2 Ethernet/IEEE 802.3 interface(s)
2 Serial network interface(s)
32K bytes of nonvolatile configuration memory.
16384K bytes of processor board System flash (Read ONLY)
Configuration register is 0x2102
The service config option is disabled by default.
However, if the router tries to boot but cannot find its startup
configuration file, it will automatically enable this option to
attempt to find a configuration file through the network:
00:00:25: AUTOINSTALL: Ethernet0 is assigned 172.25.1.30 00:00:25: AUTOINSTALL: Obtain siaddr 172.25.1.3 (as config server) 00:00:25: AUTOINSTALL: Obtain default router (opt 3) 172.25.1.3 %Error opening tftp://172.25.1.3/network-confg (No such file or directory) %Error opening tftp://172.25.1.3/cisconet.cfg (No such file or directory) %Error opening tftp://172.25.1.3/router-confg (No such file or directory) %Error opening tftp://172.25.1.3/ciscortr.cfg (No such file or directory) %Error opening tftp://172.25.1.3/network-confg (No such file or directory) %Error opening tftp://172.25.1.3/cisconet.cfg (No such file or directory)
Two interesting things happen if you reload a router with an
empty configuration file. First, the router enables its autoinstall option and attempts to acquire an
IP address via DHCP. In this example, the router obtained a DHCP
address of 172.25.1.30
. Second,
after it obtains a dynamic address, it attempts to load a
configuration file via TFTP.
Notice the filenames that the router cycles through in an
attempt to load a configuration file. If there happened to be a file
with one of these names in the TFTP directory for some other reason,
this router will have downloaded it and used its contents to configure
itself, which could have caused serious problems.
It looks like the tcpdump
output contains only requests and not any responses at all. If this is what is actually happening, then a timeout error is to be expected.
In the server_args
line of your TFTP configuration for xinetd, you have -u tftp
. That tells in.tftpd
to run as user tftp
. In light of that, this message logged by in.tftpd
might be important:
Jan 15 13:13:21 tools in.tftpd[7955]: no user tftp: Success
It says «no user tftp». Does the tftp
user account actually exist on your system?
The Success
at the end of the log message requires a bit of C programming knowledge to understand. It is likely to come from a minimalist error-handling function that probably just calls perror()
and then does any necessary clean-up before exiting.
The perror()
function takes a message from its caller and then appends to it a standard error message corresponding to the current value of the errno
variable. It is designed to be used in situations where a previous system call has failed; the custom message should describe what the program was doing when the error was encountered, and the standard message should then clarify the type of problem encountered.
But if the programmer has used their error-handling function to report an error that has been caught some other way, the standard error message part will read Success
.
My guess is that the in.tftpd
process gets started by xinetd
, prepares to switch to user tftp
, and finds out that such user does not exist. So the in.tftpd
process outputs that log message and dies without sending anything to the client.
The terse message with a misleading «Success» at the end is an example of the old concept of «if your only tool is a hammer, you tend to treat everything as nails.» In this case, the programmer has probably used their only error handling function in a situation to which its output format does not quite fit.
Also, these requests look a little odd:
12:34:33.477401 IP 172.16.1.202.ah-esp-encap > tools.dmz.tuxme.dk.tftp: 27 RRQ "pxelinux.0" octet tsize 0
12:34:35.481131 IP 172.16.1.202.acp-port > tools.dmz.tuxme.dk.tftp: 27 RRQ "pxelinux.0" octet tsize 0
12:34:39.490793 IP 172.16.1.202.msync > tools.dmz.tuxme.dk.tftp: 27 RRQ "pxelinux.0" octet tsize 0
12:34:45.477712 IP 172.16.1.202.gxs-data-port > tools.dmz.tuxme.dk.tftp: 27 RRQ "pxelinux.0" octet tsize 0
12:34:53.441801 IP 172.16.1.202.vrtl-vmf-sa > tools.dmz.tuxme.dk.tftp: 27 RRQ "pxelinux.0" octet tsize 0
The tsize 0
indicates the client is expecting a TFTP transfer with a file size of 0 bytes total.
Are you aware that the UEFI PXE specification, as it existed in UEFI version 2.3 or so, requires the DHCP server to tell the PXE client the size of the file it’s supposed to load? If you’re using ISC DHCP server, the required option could be specified as
option boot-size <size value>;
The <size value>
should be the size of the boot file in bytes divided by 512, then rounded up.