Works fine here:
root@OpenWrt:~# cd /tmp/
root@OpenWrt:/tmp# wget http://downloads.openwrt.org/releases/19.07.5/packages/mipsel_24kc/packages/Packages.gz
--2021-01-04 13:18:18-- http://downloads.openwrt.org/releases/19.07.5/packages/mipsel_24kc/packages/Packages.gz
Resolving downloads.openwrt.org... 2a01:4f8:251:321::2, 168.119.138.211
Connecting to downloads.openwrt.org|2a01:4f8:251:321::2|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 414763 (405K) [application/octet-stream]
Saving to: 'Packages.gz'
Packages.gz 100%[===================>] 405.04K 1.49MB/s in 0.3s
2021-01-04 13:18:18 (1.49 MB/s) - 'Packages.gz' saved [414763/414763]
root@OpenWrt:/tmp# zcat Packages.gz | head -n 5
Package: acl
Version: 2.2.53-1
Depends: libc, libacl
License: LGPL-2.1 GPL-2.0
Section: utils
root@OpenWrt:/tmp#
Also:
Connecting to 45.89.228.168:80
HTTP error 404
$ whois 45.89.228.168
% This is the RIPE Database query service.
% The objects are in RPSL format.
%
% The RIPE Database is subject to Terms and Conditions.
% See http://www.ripe.net/db/support/db-terms-conditions.pdf
% Note: this output has been filtered.
% To receive output for a database update, use the "-B" flag.
% Information related to '45.89.228.0 - 45.89.229.255'
% Abuse contact for '45.89.228.0 - 45.89.229.255' is 'noc@baxet.ru'
inetnum: 45.89.228.0 - 45.89.229.255
netname: RU-BAXET-20190626
country: RU
org: ORG-LB145-RIPE
admin-c: AP29217-RIPE
tech-c: AP29217-RIPE
status: ASSIGNED PA
mnt-by: IP-RIPE
mnt-routes: BX-NOC
mnt-domains: BX-NOC
created: 2019-06-26T06:42:36Z
last-modified: 2019-06-26T06:42:36Z
source: RIPE
organisation: ORG-LB145-RIPE
org-name: LLC Baxet
org-type: OTHER
descr: http://justhost.ru
address: Zelenograd, Sosnovaya alleya, 4 str 2, office 120
address: 124489 Moscow
address: Russia
abuse-c: BN2044-RIPE
mnt-ref: IP-RIPE
mnt-by: IP-RIPE
created: 2018-11-02T13:40:02Z
last-modified: 2018-11-02T13:40:50Z
source: RIPE # Filtered
person: Anton Pankratov
remarks: http://justhost.ru
address: Zelenograd, Sosnovaya alleya, 4 str 2, office 120
address: 124489 Moscow
address: Russia
phone: +7 495 6680903
nic-hdl: AP29217-RIPE
mnt-by: IP-RIPE
created: 2018-11-02T13:40:01Z
last-modified: 2018-11-02T13:41:22Z
source: RIPE # Filtered
% Information related to '45.89.228.0/23AS49392'
route: 45.89.228.0/23
origin: AS49392
mnt-by: BX-NOC
created: 2019-06-28T08:43:53Z
last-modified: 2019-06-28T08:43:53Z
source: RIPE
% This query was served by the RIPE Database Query Service version 1.99 (HEREFORD)
Something is messing with your HTTP and/or DNS connections. The IP address 45.89.228.168
does not belong to OpenWrt.
Problem:
When running opkg update
or other opkg
commands in OpenWRT, you see these error messages:
Failed to send request: Operation not permitted
Full log example:
Downloading http://downloads.openwrt.org/releases/19.07.5/targets/ath79/generic/packages/Packages.gz Failed to send request: Operation not permitted *** Failed to download the package list from http://downloads.openwrt.org/releases/19.07.5/targets/ath79/generic/packages/Packages.gz Downloading http://downloads.openwrt.org/releases/19.07.5/targets/ath79/generic/kmods/4.14.209-1-b84a5a29b1d5ae1dc33ccf9ba292ca1d/Packages.gz Failed to send request: Operation not permitted *** Failed to download the package list from http://downloads.openwrt.org/releases/19.07.5/targets/ath79/generic/kmods/4.14.209-1-b84a5a29b1d5ae1dc33ccf9ba292ca1d/Packages.gz [...]
Solution:
This problem is typically caused by no DNS servers being set.
First, check if you have internet access using
ping 1.1.1.1
The output should look like this (otherwise, you have no internet access):
[email protected]:~# ping 1.1.1.1 PING 1.1.1.1 (1.1.1.1): 56 data bytes 64 bytes from 1.1.1.1: seq=0 ttl=59 time=36.078 ms 64 bytes from 1.1.1.1: seq=1 ttl=59 time=33.538 ms 64 bytes from 1.1.1.1: seq=2 ttl=59 time=33.350 ms
Now try to ping techoverflow.net
:
[email protected]:~# ping techoverflow.net ping: bad address 'techoverflow.net'
This verifies that you have internet connectivity but no DNS.
Now go into LuCI, go to Network/Interfaces and edit each interface. Set Use custom DNS servers to:
1.1.1.1
and
1.0.0.1
This might not be possible for some interfaces since they have a different IP address configuraton (in that case, just proceed with the other interfaces). The configuration for the interface should now look like this:
Don’t forget to Save & Apply!
After that, retry opkg update
which should now look like this:
[email protected]:~# opkg update Downloading http://downloads.openwrt.org/releases/19.07.5/targets/ath79/generic/packages/Packages.gz Updated list of available packages in /var/opkg-lists/openwrt_core Downloading http://downloads.openwrt.org/releases/19.07.5/targets/ath79/generic/packages/Packages.sig Signature check passed. Downloading http://downloads.openwrt.org/releases/19.07.5/targets/ath79/generic/kmods/4.14.209-1-b84a5a29b1d5ae1dc33ccf9ba292ca1d/Packages.gz Updated list of available packages in /var/opkg-lists/openwrt_kmods Downloading http://downloads.openwrt.org/releases/19.07.5/targets/ath79/generic/kmods/4.14.209-1-b84a5a29b1d5ae1dc33ccf9ba292ca1d/Packages.sig Signature check passed. [...]
Hello everyone!
My opkg update both thro LUCI and CLI doesn’t wanna update, while my internet is getting routed fine.
It’s outputting this error:
Failed to send request: Operation not permitted
Failed to send request: Operation not permitted
Failed to send request: Operation not permitted
Failed to send request: Operation not permitted
Failed to send request: Operation not permitted
Failed to send request: Operation not permitted
Collected errors:
opkg_download: Failed to download https://downloads.openwrt.org/releases/21.02.0/targets/ramips/mt7621/packages/Packages.gz, wget returned 4.
opkg_download: Check your network settings and connectivity.
opkg_download: Failed to download https://downloads.openwrt.org/releases/21.02.0/packages/mipsel_24kc/base/Packages.gz, wget returned 4.
opkg_download: Check your network settings and connectivity.
opkg_download: Failed to download https://downloads.openwrt.org/releases/21.02.0/packages/mipsel_24kc/luci/Packages.gz, wget returned 4.
opkg_download: Check your network settings and connectivity.
opkg_download: Failed to download https://downloads.openwrt.org/releases/21.02.0/packages/mipsel_24kc/packages/Packages.gz, wget returned 4.
opkg_download: Check your network settings and connectivity.
opkg_download: Failed to download https://downloads.openwrt.org/releases/21.02.0/packages/mipsel_24kc/routing/Packages.gz, wget returned 4.
opkg_download: Check your network settings and connectivity.
opkg_download: Failed to download https://downloads.openwrt.org/releases/21.02.0/packages/mipsel_24kc/telephony/Packages.gz, wget returned 4.
opkg_download: Check your network settings and connectivity.
I have a setup like this where the MI4AG and LEDE routers are on 2.x and same submask (the LEDE has dhcp on, disabled that for the mi4ag)
They route the internet fine, I just cannot use opkg tho :/
Any tips? I’m assuming I’m just horrible at setting up this multi router setup I have, as I’m clueless regarding networking.
Any help is appreciated! Thank you!
EDIT: Pinging doesn’t work either thro Diagnostics tab, posted errors down below in the comments.
and today, another few months later:
root@shark:~# opkg update Downloading http://downloads.hak5.org/packages/shark/1907//Packages.gz *** Failed to download the package list from http://downloads.hak5.org/packages/shark/1907//Packages.gz Downloading http://downloads.openwrt.org/releases/18.06-SNAPSHOT/targets/ramips/mt76x8/packages/Packages.gz Updated list of available packages in /var/opkg-lists/openwrt_core Downloading http://downloads.openwrt.org/releases/18.06-SNAPSHOT/targets/ramips/mt76x8/packages/Packages.sig Signature check passed. Downloading http://downloads.openwrt.org/releases/18.06-SNAPSHOT/packages/mipsel_24kc/base/Packages.gz Updated list of available packages in /var/opkg-lists/openwrt_base Downloading http://downloads.openwrt.org/releases/18.06-SNAPSHOT/packages/mipsel_24kc/base/Packages.sig Signature check passed. Downloading http://downloads.openwrt.org/releases/18.06-SNAPSHOT/packages/mipsel_24kc/luci/Packages.gz Updated list of available packages in /var/opkg-lists/openwrt_luci Downloading http://downloads.openwrt.org/releases/18.06-SNAPSHOT/packages/mipsel_24kc/luci/Packages.sig Signature check passed. Downloading http://downloads.openwrt.org/releases/18.06-SNAPSHOT/packages/mipsel_24kc/packages/Packages.gz Updated list of available packages in /var/opkg-lists/openwrt_packages Downloading http://downloads.openwrt.org/releases/18.06-SNAPSHOT/packages/mipsel_24kc/packages/Packages.sig Signature check passed. Downloading http://downloads.openwrt.org/releases/18.06-SNAPSHOT/packages/mipsel_24kc/routing/Packages.gz Updated list of available packages in /var/opkg-lists/openwrt_routing Downloading http://downloads.openwrt.org/releases/18.06-SNAPSHOT/packages/mipsel_24kc/routing/Packages.sig Signature check passed. Downloading http://downloads.openwrt.org/releases/18.06-SNAPSHOT/packages/mipsel_24kc/telephony/Packages.gz Updated list of available packages in /var/opkg-lists/openwrt_telephony Downloading http://downloads.openwrt.org/releases/18.06-SNAPSHOT/packages/mipsel_24kc/telephony/Packages.sig Signature check passed. Collected errors: * opkg_download: Failed to download http://downloads.hak5.org/packages/shark/1907//Packages.gz, wget returned 8.
… still broken, but I wonder why i see this double «//» at the end of the link. When opening with Firefox, I can download the package (with both «/» single and «//» double) but not with wget:
root@shark:~# wget http://downloads.hak5.org/packages/shark/1907//Packages.gz Downloading 'http://downloads.hak5.org/packages/shark/1907//Packages.gz' Connecting to 172.217.168.83:80 Failed to redirect to /packages/shark/1907//Packages.gz on downloads.hak5.org root@shark:~# wget http://downloads.hak5.org/packages/shark/1907/Packages.gz Downloading 'http://downloads.hak5.org/packages/shark/1907/Packages.gz' Connecting to 172.217.168.83:80 Failed to redirect to /packages/shark/1907/Packages.gz on downloads.hak5.org
The issue is probably the redirect from the original link to https and then to googleapis.com:
http://downloads.hak5.org/packages/shark/1907/Packages.gz -> (307 Internal Redirect (HSTS)) or (302 with wget on ubuntu): https://downloads.hak5.org/packages/shark/1907/Packages.gz
https://downloads.hak5.org/packages/shark/1907/Packages.gz -> 301: https://storage.googleapis.com/hak5-dl.appspot.com/packages/shark/1907/Packages.gz
https://storage.googleapis.com/hak5-dl.appspot.com/packages/shark/1907/Packages.gz
Hello All,
My name is David, I’m new to this forum. I’m trying to build the WiFi radio project. I’ve found it quite easy to follow the instructions and have had what seems success up until I try to update packages. Sorry for the long post buy I’ll try to include all the pertinent configuration information and results so-far. Perhaps someone can suggest a way to get the package update working. I think perhaps I need to punch a hole in one of the boxes in my network(?)
The network looks like this:
DOCSIS-><-Cable Modem-><-Wired Router- LANGW @ 192.168.1.1/24-><-Wired Switch-><-Wireless Router-LANGW @ 10.0.1.1/24-><-WL-520GU as Device SSH @ 10.0.1.254/24-><-PC Wireless SSH
You might ask why the network is configured this way. The edge router is locked down pretty tight — no wireless is desired there. The internal wireless box is only for trivial device connections and is a pretty old WiFi router, really not suitable for the edge. I want to be able to move the WL-520GU as a portable music player.
I’ve followed all the instructions on setting up networking and the package repository. The post-configuration file dumps are below. The DNS servers are OpenDNS. The WL-520GU works as advertised when flashed with factory firmware. So the hardware is OK.
I can resolve and ping Yahoo.com and mightyohm.com when logged into the WL-520GU via wireless SSH to 10.0.1.254. So I’m able to access the Internet, at least with ICMP and for DNS lookups. The AIR LED and Power LED on the WL-520GU are lit.
My PC has no problem browsing the Web via wireless router with gateway address 10.0.1.1
The wireless router with gateway address is giving my PC a lease address of 10.0.1.100, I don’t know how to find the DHCP lease in OpenWrt. It doesn’t seem to be in the obvious places (help please?)
I then try to fetch packages:
root@OpenWrt:~# opkg update
Downloading http://mightyohm.com/files/kamikaze-2.4 … ackages.gz
Connecting to mightyohm.com (98.129.212.1:80)
wget: cannot connect to remote host (98.129.212.1): Connection timed out
Signiture check for snapshots skipped because GPG support was not enabled in this build
Collected errors:
* opkg_download: ERROR: Command failed with return value 1: `wget —passive-ftp -P /tmp/opkg-dBCbGz http://mightyohm.com/files/kamikaze-2.4 … ackages.gz’
root@OpenWrt:~#
Hmmm….
But there’s no problem resolving and pinging mightyohm.com from within the WL-520GU:
root@OpenWrt:~# ping mightyohm.com
PING mightyohm.com (98.129.212.1): 56 data bytes
64 bytes from 98.129.212.1: seq=0 ttl=48 time=221.047 ms
64 bytes from 98.129.212.1: seq=1 ttl=48 time=231.072 ms
64 bytes from 98.129.212.1: seq=3 ttl=48 time=232.499 ms
64 bytes from 98.129.212.1: seq=4 ttl=48 time=220.125 ms
64 bytes from 98.129.212.1: seq=5 ttl=48 time=231.852 ms
— mightyohm.com ping statistics —
6 packets transmitted, 5 packets received, 16% packet loss
round-trip min/avg/max = 220.125/227.319/232.499 ms
root@OpenWrt:~#
Code: Select all
---- WL-520GU Configuration ----
root@OpenWrt:~# cat /etc/config/network
#### VLAN configuration
config switch eth0
option vlan0 "1 2 3 4 5*"
option vlan1 "0 5"
#### Loopback configuration
config interface loopback
option ifname "lo"
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
#### LAN configuration
config interface lan
option type bridge
option ifname "eth0.0"
option proto static
option ipaddr 10.0.1.254
option netmask 255.255.255.0
option gateway 10.0.1.1
option dns 208.67.222.222 208.67.220.220
#### WAN configuration
config interface wan
option ifname "eth0.1"
option proto dhcp
root@OpenWrt:~#
----
root@OpenWrt:~# cat /etc/config/wireless
config wifi-device wl0
option type broadcom
option channel 11
# REMOVE THIS LINE TO ENABLE WIFI:
#option disabled 1
config wifi-iface
option device wl0
option network lan
option mode sta
option ssid Lepton-01
option encryption psk
option key ar820sdf934453jwkd3168fnfs982398
root@OpenWrt:~#
----
root@OpenWrt:~# cat /etc/opkg.conf
#src/gz snapshots http://downloads.openwrt.org/snapshots/brcm-2.4/packages
src/gz snapshots http://mightyohm.com/files/kamikaze-2.4/packages/mipsel
dest root /
dest ram /tmp
lists_dir ext /var/opkg-lists
root@OpenWrt:~#
----
Moderator: Moderators
-
cklbjkzkadmin
- Posts: 4
- Joined: Thu Jul 19, 2018 5:11 am
TroubleShooter-opkg-update-error
Successful avoid opkg update error when it’s belong to wget ssl certificate check problem,Main way is patch wget-ssl to avoid ssl certificate check,can do it by edit wget’s source code and recompile it or use reverse tool to patch it , and I choosed the last way since I don’t need configration cross compile enviroment.but I cannot post a link or pic here..so you may want to check my github for more infomation.
link here,please remove tags to check it,have to bypass forum’s link check.
https://github.com/Arryboom/wget_nossl_check
-
Lantis
- Moderator
- Posts: 6512
- Joined: Mon Jan 05, 2015 5:33 am
- Location: Australia
Re: TroubleShooter-opkg-update-error
Post
by Lantis » Thu Jul 19, 2018 6:58 am
I appreciate the effort to do this, but it is MUCH simpler to just patch the source and compile.
Also, i think one of your errors would go away by reading this thread: viewtopic.php?f=5&t=11432
Which might remove the need to do this entirely?
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.
-
cklbjkzkadmin
- Posts: 4
- Joined: Thu Jul 19, 2018 5:11 am
Re: TroubleShooter-opkg-update-error
Post
by cklbjkzkadmin » Thu Jul 19, 2018 10:34 pm
Thanks Lantis ,yes I’ve been followed your directions change the «downloads.openwrt» to «archive.openwrt» in the /etc/opkg.conf in a fresh installed Gargoyle,but doesn’t work too,and same error because of invalid certificate,guess letsencrypt’s certificate(openwrt..org’s certificate was from this certification authority) not in the trust list of our trusted certificate storage.when it comes first I tried download certificate of oppeennwwrt(maybe a black list word?) manually and then import into certs storage,like «cat oppwwrt.pem >> /etc/pki/tls/certs/ca-bundle.crt»,but can’t find /etc/pki path in our Gargoyle,not very sure there was a certificate storage in our filesystem,so then redirect on modify wget
-
Lucky
- Сообщения: 49
- Зарегистрирован: 21 мар 2019, 15:01
При установке любых программ вываливаются ошибки. (mipsel-3.4)
Код: Выделить всё
Package oscam-emu version 2018-04-18-r11420_r769-1b has no valid architecture, ignoring.
Package ext-ui version 0.4-5a has no valid architecture, ignoring.
Package libdvbcsa version 1.1.0-1a has no valid architecture, ignoring.
Package oscam-emu version 2018-04-18-r11420_r769-1b has no valid architecture, ignoring.
Package ext-ui version 0.4-5a has no valid architecture, ignoring.
Package libdvbcsa version 1.1.0-1a has no valid architecture, ignoring.
Package oscam-emu version 2018-04-18-r11420_r769-1b has no valid architecture, ignoring.
Package ext-ui version 0.4-5a has no valid architecture, ignoring.
Package libdvbcsa version 1.1.0-1a has no valid architecture, ignoring.
Package oscam-emu version 2018-04-18-r11420_r769-1b has no valid architecture, ignoring.
Плюс на bin.entware.net исчезла страница со списком пакетов.
Код: Выделить всё
https://bin.entware.net/mipselsf-k3.4/Packages.html
-
Zyxmon
- Администратор
- Сообщения: 1904
- Зарегистрирован: 09 авг 2015, 15:33
Сообщение Zyxmon » 03 июл 2020, 10:42
Lucky, а что у Вас в файле /opt/etc/opkg.conf — покажите его содержание.
-
Lucky
- Сообщения: 49
- Зарегистрирован: 21 мар 2019, 15:01
Сообщение Lucky » 03 июл 2020, 10:56
Zyxmon,
Код: Выделить всё
# cat /opt/etc/opkg.conf
src/gz entware http://bin.entware.net/mipselsf-k3.4
dest root /
lists_dir ext /opt/var/opkg-lists
arch all 100
arch mipsel-3x 150
arch mipsel-3.4 160
Вываливаться стали после обновления всех пакетов
-
Lucky
- Сообщения: 49
- Зарегистрирован: 21 мар 2019, 15:01
Сообщение Lucky » 03 июл 2020, 11:11
На 4pda видел несколько сообщений с теми же ошибка еще от 20 июня, видимо просто я поздно обновился.
-
Zyxmon
- Администратор
- Сообщения: 1904
- Зарегистрирован: 09 авг 2015, 15:33
Сообщение Zyxmon » 03 июл 2020, 11:20
Lucky, похоже Вы ставите пакеты для кинетика на обычное mipsel устройство.
Если же у Вас кинетик то —
1. Вспомните, что делали в последнее время. Желательно подробно. Напишите.
2. Допишите в opkg.conf строку `arch mipsel-3.4_kn 210` далее стандартно — `opkg update; opkg upgrade`
-
Lucky
- Сообщения: 49
- Зарегистрирован: 21 мар 2019, 15:01
Сообщение Lucky » 03 июл 2020, 11:32
Zyxmon,
Нет у меня не кинетик, прошивка от Padavan’a. Entware был развернут и работал, все что я сделал, это обновил пакеты командами opkg update; opkg upgrade.
А сейчас вот такое.
Код: Выделить всё
opkg update && opkg upgrade
Downloading http://bin.entware.net/mipselsf-k3.4/Packages.gz
Updated list of available packages in /opt/var/opkg-lists/entware
Package astra-sm version 0.2.88-2c has no valid architecture, ignoring.
Package dvb-center version 0.2-3b has no valid architecture, ignoring.
Package dvb-firmware version 1.0-5 has no valid architecture, ignoring.
Package ext-ui version 0.4-5a has no valid architecture, ignoring.
Package ext-ui-lighttpd version 0.4-5a has no valid architecture, ignoring.
Package ext-ui-nginx version 0.4-5a has no valid architecture, ignoring.
Package iptables version 1.4.21-3 has no valid architecture, ignoring.
Package kmod_ndms version 24-5a has no valid architecture, ignoring.
Package libdvbcsa version 1.1.0-1a has no valid architecture, ignoring.
Package libndm version 1.1.10-2 has no valid architecture, ignoring.
Package list-smargo-emu version 2018-04-18-r11420_r769-1b has no valid architecture, ignoring.
Package minisatip_ndms version 0.7-1a has no valid architecture, ignoring.
Package music-center version 0.1-6 has no valid architecture, ignoring.
Package ndmq version 1.0.2-6 has no valid architecture, ignoring.
Package opt-ndmsv2 version 1.0-12a has no valid architecture, ignoring.
Package oscam-emu version 2018-04-18-r11420_r769-1b has no valid architecture, ignoring.
Package poorbox version 1.31.1-3 has no valid architecture, ignoring.
Package scan-s2 version 1.0-4b has no valid architecture, ignoring.
Package tvheadend_ndms version 4.2.6-5c has no valid architecture, ignoring.
Package tvheadend_ndms_devel version 4.3.0-6c has no valid architecture, ignoring.
Package w_scan version 20170107-1b has no valid architecture, ignoring.
-
Zyxmon
- Администратор
- Сообщения: 1904
- Зарегистрирован: 09 авг 2015, 15:33
Сообщение Zyxmon » 03 июл 2020, 11:56
Все понятно, спасибо. Пока игнорируйте эти ошибки. Сегодня починим и после opkg update они исчезнут.
-
Lucky
- Сообщения: 49
- Зарегистрирован: 21 мар 2019, 15:01
Сообщение Lucky » 03 июл 2020, 13:35
Zyxmon,
Все, ошибки ушли. А почему adguardhome убрали в кинетик? На Padavan’e работает без проблем.
-
Lucky
- Сообщения: 49
- Зарегистрирован: 21 мар 2019, 15:01
Сообщение Lucky » 25 мар 2021, 16:55
Добрый день.
Код: Выделить всё
cat /opt/etc/opkg.conf
src/gz entware http://bin.entware.net/aarch64-k3.10
dest root /
dest ram /opt/tmp
lists_dir ext /opt/var/opkg-lists
option tmp_dir /opt/tmp
arch all 100
arch aarch64-3.10 160
Отвалились все пакеты после обновления, выбивает Segmentation fault. Работает только htop и то как-то криво.
-
Zyxmon
- Администратор
- Сообщения: 1904
- Зарегистрирован: 09 авг 2015, 15:33
Сообщение Zyxmon » 25 мар 2021, 19:53
Lucky, в течении нескольких часов был немного кривой репозиторий, исправил около полуночи с 23 на 24 по московскому времени.
Если в файле /opt/lib/opkg/status имеются строки `Version: unknown-11` — то это Ваш случай (максимум 4 строки). Тогда нужно в этом файле заменить `unknown` на `8.4.0` и после этого повторно запустить установку поверх имеющейся. Все должно починиться.
Можно с нуля все переустановить, если что….
PS У меня обновление с кривым репозиторием прошло нормально. Но у других может быть хуже.
Если строк с unknown нет — возможно Ваше неизвестное устройство несовместимо с Entware. В следующий раз указывайте устройство, приводите версию ядра.
Кто сейчас на конференции
Всего 8 посетителей :: 0 зарегистрированных, 0 скрытых и 8 гостей (основано на активности пользователей за последние 5 минут)
Больше всего посетителей (162) здесь было 16 ноя 2019, 18:33
Сейчас этот форум просматривают: нет зарегистрированных пользователей и 8 гостей